buzz forums

forums of the buzz
It is currently Thu Feb 20, 2020 6:03 am

All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Sat Jul 02, 2016 5:09 am 

Joined: Thu Jun 30, 2016 11:59 am
Posts: 17
Hi people,

If anyone could shed some light on this for me that would be greatly appreciated. I can't see anything about this in the midi section of the manual!

http://buzzwiki.robotplanet.dk/index.ph ... IDI_Output

I would like Buzz to be in sync with all the other external stuff I use, and for Buzz (on my laptop) to be the 'master'.

This was really what my other questions in my other post about about polac asio were about.

Any advice is much appreciated.

Peace from NZ


Top
 Profile  
 
PostPosted: Sun Jul 03, 2016 11:05 am 

Joined: Wed Nov 23, 2011 9:19 am
Posts: 267
Imo best way for external midi output is to use one of my waveout drivers like polac asio or wdm. Then you can use polac vst to send midi to your external midi devices. You find and select your midi devices in polac vst via MIDI submenu.

Also deselect all midi outputs in the buzz preferences to be one the safe side at first.


Top
 Profile  
 
PostPosted: Sun Jul 03, 2016 12:08 pm 

Joined: Thu Jun 30, 2016 11:59 am
Posts: 17
polac wrote:
Imo best way for external midi output is to use one of my waveout drivers like polac asio or wdm. Then you can use polac vst to send midi to your external midi devices. You find and select your midi devices in polac vst via MIDI submenu.

Also deselect all midi outputs in the buzz preferences to be one the safe side at first.


So if I can't get polac asio to work on my computer, are you saying that 'wdm' could be another to do it? That sounds promising! I just clicked the wdm kernel streaming option in preferences, then apply, then config, and I see it is coming up with no error, it is giving me some options.

I must go to sleep now but I'll be back to experiment with that tomorrow night!

Any basic tips about using wdm would be appreciated.

Peace! :dance:


Top
 Profile  
 
PostPosted: Thu Jul 07, 2016 12:21 pm 

Joined: Thu Jun 30, 2016 11:59 am
Posts: 17
Hi again people,

Thanks for your help on this! OK so I have solved the 'asio initialization failed' problem I was having in the other post. I am now able to see the config screen pop up when I click on polac asio in the preferences.

So now I'm back to this question: how do I send play/stop/pause messages from Buzz to external devices through my 'edirol UM-1X' usb interface?

If anyone could explain this step by step for me, assuming I am far from a computer genius, that would be much appreciated.

Polac I did try to follow your advice above, but I didn't understand what you meant by:

polac wrote:
You find and select your midi devices in polac vst via MIDI submenu.



I'm guessing you mean when I right click on 'polac vst' a list pops up - then I click on 'Midi send'. However it then says "Midi out port" is "not supported by plugin", and "Machines" says "no plugin loaded". (My midi interface is an 'Edirol UM-1X' usb midi interface).

(I did use Buzz a lot 2000 - 2005. I just used the internal sounds, and samples that I used on the Matilde tracker. Nothing too fancy. But I did come up with some crazy sounds!) But I am trying to be fancier now.

Thank you!


Top
 Profile  
 
PostPosted: Mon Jul 11, 2016 9:42 am 

Joined: Thu Jun 30, 2016 11:59 am
Posts: 17
I'm on the verge of getting creative again, I just need to sync Buzz up with the rest of my system.

But I'm still trying to work out how to use Polac devices to control external hardware.

Which of the ten Polac machines should I use, and how?

Cheers people!

Peace


Top
 Profile  
 
PostPosted: Tue Jul 12, 2016 2:50 pm 

Joined: Tue Dec 06, 2011 6:54 pm
Posts: 265
Silent way do a lot of good midi plugins

http://www.expert-sleepers.co.uk/silentway.html


Top
 Profile  
 
PostPosted: Tue Jul 12, 2016 6:40 pm 

Joined: Wed Nov 23, 2011 9:19 am
Posts: 267
Quote:
I'm guessing you mean when I right click on 'polac vst' a list pops up - then I click on 'Midi send'. However it then says "Midi out port" is "not supported by plugin", and "Machines" says "no plugin loaded". (My midi interface is an 'Edirol UM-1X' usb midi interface).


It should at least show your edirol device at the midi out port box, odd. Do you have the edirol device activated in the buzz preferences(midi output tab)? If yes, try to deactivate it. Also you possibly have to rescan the shell plugins again, see the loader preferences/global 2 tab.

Quote:
You find and select your midi devices in polac vst via MIDI submenu.


What I meant is the midi submenu in the plugin menu. Rightclick polac vsti to see the plugin menu.

Quote:
So now I'm back to this question: how do I send play/stop/pause messages from Buzz to external devices through my 'edirol UM-1X' usb interface?


Polac vsti sends play/stop/pause(midi clock messages) too.


Top
 Profile  
 
PostPosted: Fri Jul 15, 2016 10:14 pm 

Joined: Thu Jun 30, 2016 11:59 am
Posts: 17
polac wrote:
Quote:
I'm guessing you mean when I right click on 'polac vst' a list pops up - then I click on 'Midi send'. However it then says "Midi out port" is "not supported by plugin", and "Machines" says "no plugin loaded". (My midi interface is an 'Edirol UM-1X' usb midi interface).


It should at least show your edirol device at the midi out port box, odd. Do you have the edirol device activated in the buzz preferences(midi output tab)? If yes, try to deactivate it. Also you possibly have to rescan the shell plugins again, see the loader preferences/global 2 tab.

Quote:
You find and select your midi devices in polac vst via MIDI submenu.


What I meant is the midi submenu in the plugin menu. Rightclick polac vsti to see the plugin menu.

Quote:
So now I'm back to this question: how do I send play/stop/pause messages from Buzz to external devices through my 'edirol UM-1X' usb interface?


Polac vsti sends play/stop/pause(midi clock messages) too.


Where I went wrong I think was I was using Polac VST instead of Polac VSTi. I also wasn't connecting it to Master, which meant my midi interface was not showing up in the "plugins->midi" list.

It's great to have these synced up finally, thank you for your help and thank you for your inventions!


Top
 Profile  
 
PostPosted: Fri Jul 15, 2016 10:35 pm 

Joined: Thu Jun 30, 2016 11:59 am
Posts: 17
1) Download the Polac VST Loaders for Jeskola Buzz from here: http://www.xlutop.com/buzz/

Most people recommend the 32 bit version of Buzz, in which case, click "Download (x86)" (x86 means the 32 bit version)

2) Once you have downloaded these, follow magmavander's instructions for where to put all the downloaded stuff: https://www.youtube.com/watch?v=AW0PayGBGVs

3) Load Buzz. From Machines Editor Window (you get there if you push F3), run a search in your Machines for 'polac'. Click and drag "Polac VSTi 1.1" from the list and into the Machines Editor Window. Plug it into the "Master".

4) Right click on your Polac VSTi machine. Go to Plugins, a sub menu should appear which lists your USB interface. Click on that. Polac VSTi should now be renamed with the name of your USB interface.

5) Double click on it. Turn number 0 (Midi Clock) to 'on', and turn number 7 (MTC/MMC) to either MTC or MMC (as opposed to 'off'). I use MTC because it is recommended by the manufacturers of my particular external hardware device, but yours could be different.

Peace!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group