buzz forums
http://forums.jeskola.net/

[SOLVED] Tiny bug in preferences?
http://forums.jeskola.net/viewtopic.php?f=2&t=2152
Page 1 of 1

Author:  AndersBrontosaurus [ Mon Jul 04, 2016 9:08 pm ]
Post subject:  [SOLVED] Tiny bug in preferences?

I've discovered a small issue which may be a bug. Most of the time I use an external Novation usb-soundcard but sometimes if I'm at work and leave it at home I have to use the internal one.
If i used Buzz last time with the external soundcard and the appropriate driver (which will be Novation usb asio) I will get the errormessage "Asio initialization failed" when I start Buzz without the external soundcard connected. I have not found a way to use asio 4 all if initiallzation have failed so I have to suffice with Wasapi until I get home. This is no real problem for me. (At least not until my soundcard breaks and I won't be able to revert to Asio4all.) I just thought I should post it since there's another post about Asio initialization at the moment.

Anders

Author:  UNZ [ Tue Jul 05, 2016 9:35 am ]
Post subject:  Re: Tiny bug in preferences?

you should still be able to get into the pvst CONFIG dialog and change the driver to asio4all.

otherwise you'll have to delete HKEY_CURRENT_USER\Software\Jeskola\Buzz\Polac ASIO

Author:  AndersBrontosaurus [ Fri Jul 08, 2016 7:46 pm ]
Post subject:  Re: Tiny bug in preferences?

UNZ wrote:
you should still be able to get into the pvst CONFIG dialog and change the driver to asio4all.

otherwise you'll have to delete HKEY_CURRENT_USER\Software\Jeskola\Buzz\Polac ASIO


Well the problem is that when I click "config" nothing happens, the window doesn't popup.
I assume I could set driver to wasapi and reboot computer. This should avoid the errormessage "Asio initialization failed" at Buzz startup, go to prefs and change back from wasapi to polac asio and hopefully it works.

Great that there is the other solution, to delete HKEY* too.

/Anders

Author:  UNZ [ Mon Jul 11, 2016 6:07 pm ]
Post subject:  Re: [SOLVED] Tiny bug in preferences?

iirc this bug has been around forever. its two fold because its partly a usability issue imho. you select the driver, but you can't immediately click config, you have to click apply first (or restart buzz..) to be able to click config and get into the selected driver's config menu. pretty stupid imho, it should just switch to the driver immediately, like the dropdown in the menu-bar does. the other part is that once the registry is fucked up (because some device is not connected anymore or so) there seems to be a possibility to end up in a state where you really have to mess with the registry (i had to do it once or twice too). this obviously should never happen.

Author:  polac [ Tue Jul 12, 2016 6:30 pm ]
Post subject:  Re: [SOLVED] Tiny bug in preferences?

I really have to fix this one.

Author:  boombaxx [ Wed Apr 04, 2018 12:50 pm ]
Post subject:  Re: [SOLVED] Tiny bug in preferences?

Still not fixed run into this today hate messing about with the registry

Author:  polac [ Wed Apr 04, 2018 7:37 pm ]
Post subject:  Re: [SOLVED] Tiny bug in preferences?

Sorry for not fixing this one :mrgreen:. As I'm fiddling around with the loaders again I will fix this bug then too.

Author:  boombaxx [ Thu Apr 05, 2018 9:36 am ]
Post subject:  Re: [SOLVED] Tiny bug in preferences?

Wow that would be great. I have tried every hack and fix none of them worked. I did get it to change error message that was about it. Also i am having problem renaming presets if prevent focus stealing is on. It plays the notes rather than type letters

Author:  IXix [ Sat Apr 07, 2018 9:42 am ]
Post subject:  Re: [SOLVED] Tiny bug in preferences?

polac wrote:
I'm fiddling around with the loaders again

:dance: :dance: :dance: :dance: :dance: :dance: :dance: :dance: :dance:

Author:  polac [ Sun Apr 15, 2018 10:50 am ]
Post subject:  Re: [SOLVED] Tiny bug in preferences?

I think I found the asio bug, cannot test it here though, but I think fixed it now, uploading in the next days then.

Author:  IXix [ Sun Apr 15, 2018 12:15 pm ]
Post subject:  Re: [SOLVED] Tiny bug in preferences?

polac wrote:
I think I found the asio bug, cannot test it here though, but I think fixed it now, uploading in the next days then.

:dance: :dance: :dance: :dance: :dance:

Author:  boombaxx [ Sat Apr 28, 2018 10:30 am ]
Post subject:  Re: [SOLVED] Tiny bug in preferences?

Days turning into weeks

Author:  polac [ Sun Apr 29, 2018 10:18 am ]
Post subject:  Re: [SOLVED] Tiny bug in preferences?

Slightly annoyed, eh? ;) I uploaded it now, no guarantee that it works 100%.

viewtopic.php?f=3&t=7

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/