buzz forums

forums of the buzz
It is currently Tue Jun 19, 2018 12:08 pm

All times are UTC




Post new topic Reply to topic  [ 15 posts ] 
Author Message
PostPosted: Thu Jun 07, 2018 7:33 pm 

Joined: Sat Feb 25, 2017 12:27 pm
Posts: 55
Location: South-Germany
Hi experts,

now I bought my new USB2.0 audio interface. But-hearing songs in BUZZ its terrible and I had a all-night long driver session :cry: Playing mp3 via VLC is good. Even the directx realtek onboard sound was then worse in buzz!? Tried many buffer size setting, no success.
Today I found out, that I can have stable sound without heavy cracks and jumps by using the 2+3 U(async) setting in the POLAC ASIO. :) I set also the ASIO settings in the Steinberg interface to low buffer size 96 (for low latencies near 10 msec). 'The time critical priority' is needed probably. Going down to 2+2 or 64 samples some crackles come in. CPU power or RAM is definitely not the problem! 4core, 3.7 GHz, 8GB dual channel. WIN10x64.

But, I don't understand what this 2+3(async) means ?
And there are, even with big buffer size, still some little high crackles, that haven't been there before. Like electro-static crackles of records. How can I get them rid of. Some effects have high inputs, but that has been the same before installing the audio interface.

Attachment:
ASIO Settings.jpg
ASIO Settings.jpg [ 20.82 KiB | Viewed 207 times ]


Last edited by HerrFornit on Wed Jun 13, 2018 5:20 am, edited 1 time in total.

Top
 Profile  
 
PostPosted: Fri Jun 08, 2018 7:53 am 

Joined: Tue Dec 06, 2011 6:54 pm
Posts: 242
Depends on your computer speed and number of cores set it 2 sync and increase the latency settings in the control panel till the crackling stops, that setting u have on is to increase the latency by factor of 3 12 ms would be 36 4 48 and so on. it's used to get more performance when making tracks that use all your cpu power


Top
 Profile  
 
PostPosted: Fri Jun 08, 2018 8:34 am 

Joined: Sat Feb 25, 2017 12:27 pm
Posts: 55
Location: South-Germany
Hi boombaxx,

thanx for reply.
Yes, I tried this. Unfortunately in some promlemsongs, I cant get rid off the crackles totally even with highest latencies (2048). Some little crackles remain.
In some songs I can go to 128. I handn't this with onboard chip!.

If there is a chance to get it better with an other audio interface? Then I would change it.

My CPU is at 10% only. Buzz CPU monitor says in most cases around 50% (20-65%).

I use often VST instruments and effects.


Top
 Profile  
 
PostPosted: Fri Jun 08, 2018 9:25 am 

Joined: Wed Nov 23, 2011 9:19 am
Posts: 210
Quote:
Today I found out, that I can have stable sound without heavy cracks and jumps by using the 2+3 U(async) setting in the POLAC ASIO. :) I set also the ASIO settings in the Steinberg interface to low buffer size 96 (for low latencies near 10 msec). 'The time critical priority' is needed probably. Going down to 2+2 or 64 samples some crackles come in. CPU power or RAM is definitely not the problem! 4core, 3.7 GHz, 8GB dual channel. WIN10x64.

But, I don't understand what this 2+3(async) means ?
And there are, even with big buffer size, still some little high crackles, that haven't been there before. Like electro-static crackles of records. How can I get them rid of. Some effects have high inputs, but that has been the same before installing the audio interface.


2+3(async) mode does introduce some more latency,in this case the latency is 96 + (3 * 96) = 384 samples. The audio also gets processed in an separate worker thread instead of directly in the asio thread(2(sync) mode). Whats odd is that a big buffer size of 2048 in sync mode is causing crackles and 384 samples in async mode is working properly.


Top
 Profile  
 
PostPosted: Fri Jun 08, 2018 6:09 pm 

Joined: Sat Feb 25, 2017 12:27 pm
Posts: 55
Location: South-Germany
polac wrote:
2+3(async) mode does introduce some more latency,in this case the latency is 96 + (3 * 96) = 384 samples. The audio also gets processed in an separate worker thread instead of directly in the asio thread(2(sync) mode). Whats odd is that a big buffer size of 2048 in sync mode is causing crackles and 384 samples in async mode is working properly.


Yes that's strange.

Ok, Got some news. I found out, that at least one VSTeffect, the beloved cs12 equalizer is responsible for many artefacts. Especially when several instances are running within the same song. With this, its impossible to increase the sample rate more than 44.1000, because of heavy noise. Maybe that's the reason, why increasing the buffer size is of limited effect.

Now the sound is "quiet good", but about 1-3 times in a song there are still little high crackles.

But, is that normal ??? And: Is there a good chance that with other audio interfaces, all this is not the case. (For example the recommended Roland Rubix22) ???
Or do I have to live with it?


Top
 Profile  
 
PostPosted: Sat Jun 09, 2018 10:00 pm 

Joined: Sat Feb 25, 2017 12:27 pm
Posts: 55
Location: South-Germany
New suspect: (after crackles came back)

USB Coolermaster Gaming Mouse Pro L Software with high poll rate, Maybe the USB WLAN, too.

Put both at the front USB 3.0 now. Deinstalled the Coolermaster Software. Reinstalled (again) the Interface driver - unplugged CM mouse an WLAN stick before. restart ....

Maybe it helps.


Top
 Profile  
 
PostPosted: Sun Jun 10, 2018 5:03 pm 

Joined: Sat Feb 25, 2017 12:27 pm
Posts: 55
Location: South-Germany
It didnt help.

I have a free Ableton Lite license. The crackle comes rather rarely, but its also there.

I send it back an look for an USB 3.0 AI.

Thanx for hints!


Top
 Profile  
 
PostPosted: Sun Jun 10, 2018 8:11 pm 

Joined: Tue Nov 22, 2011 5:18 pm
Posts: 78
My sweet spot regarding soundcard buffer seems to be 256.In Buzz i always need to set it to 2+1 async (as opposed to ableton) otherwise i also get some crackles.Then i'm able to have the CPU peaking up to 40% (which i avoid if possible) without crackles but only if the cores are (more or less) balanced.Sometimes it happens that one core is processing too much.Clicking on Buzz's "Disable Audio Devices" (F12) one or two times often helps to re-balance the cores.Also a simple "save" seems to work well.
When the cores are balanced Windows 10 does a great job in keeping them balanced while working in a session..
This is my experience with an RME AIO (on different computers,also on a i7-3930K) and a Audient ID4 which behave similar,minus some ms better latency for the RME card.
Oh,and closing the task manager helps too.

Interestingly.For a while i worked on a Asus J1900 Board (to be forced to work with limited resources :lol: ) with my Yamaha Ag03 and i could push the CPU by far more than i ever was able to do it on a much stronger i7.

Wifi USB can be a bad thing,there are many reports about audio/asio related problems,some Asus USB-Wifi devices can work though but i avoid Wifi.

My routine when working with Windows and low latency audio is always to start Windows and let it do its start up routine for about 20 minutes (checking the task manager) ,after a while when the CPU is idle i check the maintenance window too,to see if Windows got its job done.So don't touch a mouse or keyboard otherwise Windows will stop maintenance.

I'm currently working on a i7-7700 and i'm using the inbuilt GPU,There are sometimes glitches,at least a heavy CPU strain with certain VST GUI's but this isn't bothering me.

I haven't read much comments on about how much CPU people are able to use with low latency audio but there is a certain sweet spot which i'm able to work.

Btw,before Windows 1803 i needed to manually stop the Superfetch service because i got a huge glitch every 10 minutes or so .Superfetch comes back after a restart but i'm avoiding any tweaking that's why i only stop the service.
With 1803 it seems to be much better but i only want to mention it.

Regarding USB 3 interfaces.You should thoroughly read about them if there are any problems.Usually USB 2 for a small interface is the way to go (at the moment).

I'm also using a gaming mouse, a Logitech G502 without a problem.

One more thing to mention.In Windows 1803 there is a new "ultimate performance mode" power plan which i find helps stabilizing.
http://www.thewindowsclub.com/ultimate- ... power-plan

All in all,working with low latency isn't simple at all.


Top
 Profile  
 
PostPosted: Sun Jun 10, 2018 10:44 pm 

Joined: Sat Feb 25, 2017 12:27 pm
Posts: 55
Location: South-Germany
Hi domtron,

thanx a lot for your detailed post!
Oh man, didn't think, that it is so complicated.

I did try a lot, even deactivating the USB3.0 port and onboard sound in BIOS, deactivating LAN and Wifi etc.
Didnt know, that latency is so depend on background process in days of multicore and SSD.

Perhaps I should buy a new motherboard... its an AsRock b85m-itx, only one PCIe slot. Or a new computer.
by the way, the problems occurred also with my laptop.
I have a look at the Audient ID4...


Top
 Profile  
 
PostPosted: Mon Jun 11, 2018 6:03 am 

Joined: Tue Nov 22, 2011 5:18 pm
Posts: 78
You are welcome :D

I prefer the 1151 platform (yours is So.1150),I'm also using a itx,Asus H170i-Pro.

There are cases that a interface driver can make huge problems on some boards just because (for example) when the driver is badly written.

The UR12 should have a similar driver to my Yamaha AG03 interface they are written by Yamaha too,try to use the Wasapi driver in Buzz and see if it makes any difference.

Did you work with your on board sound card? Did you use the standard Windows driver? Seems like you had not so much problems with that configuration.


Top
 Profile  
 
PostPosted: Mon Jun 11, 2018 6:24 am 

Joined: Sat Feb 25, 2017 12:27 pm
Posts: 55
Location: South-Germany
Yes, I did use onboard Realtek chip for buzzing and sometimes a Roland A49 keyboard.

I mostly used it with directX sound driver, it is more stable.
Now I'm not sure any more if I had the error with ASIO onboard, too, because perhaps it did not appear because I used ASIO not often and without many instruments/effects.
Now the crackles appear with onboard sound, too. After deinstalling the yamaha driver, it was there for directX driver, too!! I reinstalled the realtek driver (old Relatek original by Asrock delivered) and it was ok again.

Maybe the board is defect?
Buying the 1151 board means a new CPU, right? Xeon E3 1230v3. Thank you Intel.


Top
 Profile  
 
PostPosted: Mon Jun 11, 2018 6:47 am 

Joined: Tue Nov 22, 2011 5:18 pm
Posts: 78
The Xeon E3 1230v3 looks good from the benchmarks.
Right now i don't think another consumer platform like the So.1151 makes a big difference,maybe a i7-8700(k) but that's greater investment because you need DDR 4 RAM too.If you have any problems with low CPU consumption and moderate latency then maybe the board isn't up to the task but must not be defective.


So for now,my first steps would be.
Create the ultimate power plan in Windows 10,set the CPU to the default clock (min-max 3300 mhz) in there.
Turn of USB energy saving in the power plan.
Plug out and turn off Wifi.
Be sure that there are no Windows tweaks.
Do not use any USB Hub and connect only the important parts like mouse and keyboard directly.

Manually enable the power plan if you work in a DAW,it should switch back to the standard saving power plan automatically when you leave the DAW,which is a good thing.

If this doesn't help try a clean install (and try to only use the automatically delivered Windows 10 drivers for your board) or buy a So.1150 Asus board.


Top
 Profile  
 
PostPosted: Mon Jun 11, 2018 9:00 pm 

Joined: Sat Feb 25, 2017 12:27 pm
Posts: 55
Location: South-Germany
Hi Domtron!

I unboxed the retour.
How is this? !
I followed your hint and made a high performance energyplan. CPU now is at 3.6-3.7 GHz constantly.
And... it's much better. I can not believe it! :dance:
So why, 10 percent CPU usage in buzz and I had glitches because of the speed step technology?! dam it, that's crab!
Wifi is no problem by the way.
I probably keep the audio interface now. The DAC is not the best but ok. Or do you know a better one for max ca. 120,- Euros? Headphone sound is most important.

Thanx so much !

PS: I do not understand the automatic switch in standard energy plan after closing the DAW? How does it work (have still Win 1709)?


Top
 Profile  
 
PostPosted: Tue Jun 12, 2018 6:30 am 

Joined: Tue Nov 22, 2011 5:18 pm
Posts: 78
Glad it worked ;)

Some DAW's (eg. FL Studio) automatically enable the (standard) high performance plan when starting up.Buzz is not.

If you close Buzz with your custom power plan enabled,the plan should switch to the balanced plan automatically,you can see it in the power options in Windows.
That's because it enable the energy saving mode,throttle the CPU and draw less power.
If not, you can enable the balanced plan manually.

I'm using a Audient ID4 interface atm. :D


Top
 Profile  
 
PostPosted: Fri Jun 15, 2018 11:43 pm 

Joined: Tue Dec 06, 2011 6:54 pm
Posts: 242
I have a focusrite very good sound quality only thing i don't like is that it does not have an adat out. Although the head phone output can be used for that


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group