buzz forums

forums of the buzz
It is currently Tue Feb 18, 2020 6:10 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Fri Sep 20, 2019 9:40 pm 
User avatar

Joined: Mon Nov 21, 2011 7:21 pm
Posts: 306
I've tried doing something about a problem that's been annoying me for years: Whenever you load a new sample into the wave table, it kills the envelope. In 99% of all cases I want to keep the envelope.

Now, I'm no expert in wpf, so this might not be a correct fix, but it seems to work. Everyone is welcome to test this. But keep a backup of your old file just in case.

As a minor change, I've also made so that if you select a .wav file in the right-side file browser, "Enter" now loads the sound into the wave table.

http://www.robotplanet.dk/files/buzz/Bu ... Bugfix.zip


Top
 Profile  
 
PostPosted: Sat Sep 21, 2019 3:23 pm 
User avatar

Joined: Thu Nov 24, 2011 7:14 am
Posts: 301
Thank you! :dance:
I am not using samples in Buzz very often, but that is a useful fix!!


Top
 Profile  
 
PostPosted: Wed Jan 01, 2020 12:36 pm 
User avatar

Joined: Thu Mar 15, 2012 2:15 am
Posts: 98
Location: Sweden
Oh wow, you know how to make alterations to the wavetable view? I'm not sure if I have any samples with envelope, except maybe multisample .xi files that won't load anyway, to test this with, but you wouldn't happen to know how to make this button do anything, would you?
Image
The lack of ability to play selections before trimming them is the most annoying shortcoming of the wavetable editor, and I'm losing hope that Oskari will ever return to save us.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group