buzz forums

forums of the buzz
It is currently Tue Oct 17, 2017 1:50 am

All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Index.txt menu bug
PostPosted: Sun Jan 08, 2017 6:48 pm 
User avatar

Joined: Wed Nov 23, 2011 3:24 pm
Posts: 515
For a long time, I've been struggling with my index. Something causes it to put separators where there shouldn't be any. I've always assumed it was just some problem with the formatting of my own index.txt but just now I noticed that the bug even affects the lists generated by Polac VST...

Image

I tried debugging it in BuzzGUI to see if it was some simple thing but I can't tell what's going wrong. The only thing I noticed is that in BuildMachineIndexMenuItems(IMenuItem mie) every child of mie has the property IsSeparator set to true.

What's happening?

edit: Image doesn't seem to work so https://www.dropbox.com/s/n3szbs8y08i61 ... g.png?dl=0


Top
 Profile  
 
 Post subject: Re: Index.txt menu bug
PostPosted: Sun Jan 08, 2017 7:42 pm 
User avatar

Joined: Mon Nov 21, 2011 7:21 pm
Posts: 265
Not sure what's going on there, but as a test you could try my auto indexer tool.

Careful: It overwrites your current index.txt file!

www.robotplanet.dk/files/buzz/auto-indexer02.rar
The files should go into the Gear folder, and you should be inside that folder when you run it.


Top
 Profile  
 
 Post subject: Re: Index.txt menu bug
PostPosted: Sun Jan 08, 2017 8:04 pm 
User avatar

Joined: Wed Nov 23, 2011 3:24 pm
Posts: 515
Joachip wrote:
Not sure what's going on there, but as a test you could try my auto indexer tool...

Thanks. Same thing happens with the generated index, though a lot less. Some machine entries in the index are replaced with separators but I can't see any pattern to it.

My index sprawls a bit and it's formatted for easier reading/editing so I assumed it was my formatting causing it but I tried lots of different things (getting rid of whitespace, getting rid of separators etc.) and sometimes it would seem to work but then I add another machine entry or insert another separator and it goes wrong again. Sometime it seems okay but then I discover unwanted separators lurking in some submenu.

I know it used to be okay but I'm not sure when it started to go wrong. I might have to try going back through old builds because it's very frustrating.


Top
 Profile  
 
 Post subject: Re: Index.txt menu bug
PostPosted: Sun Jan 08, 2017 8:18 pm 
User avatar

Joined: Wed Nov 23, 2011 3:24 pm
Posts: 515
Here's a capture...
Image

(Image still not working, I think DropBox have changed something recently - link here: https://www.dropbox.com/s/du7lid9k4o76zk9/Index%20separators%20bug%202.png?dl=0

...and here's the relevant section of the index...
Code:
 majkol freebase, majkol freebase
 majkol freebaseBETA4, majkol freebaseBETA4

 /Matilde (5) ...
  Matilde Tracker (Mono), Matilde Tracker (Mono)
  Matilde Tracker 9, Matilde Tracker 9
  Matilde Tracker, Matilde Tracker
  Matilde Tracker2, Matilde Tracker2
  Matilde Tracker3, Matilde Tracker3
  /..

 mimo's MidiGen, mimo's MidiGen
 MT Algo, MT Algo
 MT Algo.GUI, MT Algo.GUI


As you can see, mimo's MidiGen gets clobbered in this instance.


Top
 Profile  
 
 Post subject: Re: Index.txt menu bug
PostPosted: Sun Jan 08, 2017 9:41 pm 
User avatar

Joined: Mon Nov 21, 2011 7:21 pm
Posts: 265
What the heck?!? That's really just very wrong. Something is odd there.

Maybe try bringing out the big guns: First back up your entire buzz folder. Then deinstall, delete the buzz folder, clean the buzz section of the registry, isntall a fresh one and see if that helps. Then restore the backup on top (but don't overwrite existing files).

Another test if that doesn't work: Try a different computer? Then apply the backup to that and see if the problems happens there.

PS:
Yeah, dropbox isn't doing so well lately. Their code has become as over-complicated as onedrive, and that's not a good thing. They should revert 5 years back or so. Make dropbox great again!


Top
 Profile  
 
 Post subject: Re: Index.txt menu bug
PostPosted: Sun Jan 08, 2017 10:32 pm 
User avatar

Joined: Wed Nov 23, 2011 3:24 pm
Posts: 515
Joachip wrote:
What the heck?!?...

Thanks, I'll try your suggestions and see what happens. I'm glad you agree that it's weird. :)


Top
 Profile  
 
 Post subject: Re: Index.txt menu bug
PostPosted: Mon Jan 09, 2017 11:54 am 

Joined: Wed Nov 23, 2011 9:19 am
Posts: 189
Is there an old pvsti version(better said an old machines.dll) in your folder? The old versions for oldbuzz do hack separators at least to the vst menus.


Top
 Profile  
 
 Post subject: Re: Index.txt menu bug
PostPosted: Mon Jan 09, 2017 7:31 pm 
User avatar

Joined: Wed Nov 23, 2011 3:24 pm
Posts: 515
polac wrote:
Is there an old pvsti version(better said an old machines.dll) in your folder? The old versions for oldbuzz do hack separators at least to the vst menus.

No, I think I'm all up to date with PVST (which is an astounding piece of work by the way) and besides, the bug affects the rest of the index far more than it does the PVST generated stuff so it's a Buzz thing. Hopefully Joachip's suggestion will fix it. I'm about to try it now...


Top
 Profile  
 
 Post subject: Re: Index.txt menu bug
PostPosted: Mon Jan 09, 2017 9:06 pm 
User avatar

Joined: Wed Nov 23, 2011 3:24 pm
Posts: 515
Hmmm. Fresh Buzz, nothing added except my index.txt, bug still persists. Time to try other computers...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group