new pvst beta (updated 29-Mar-2019)

Post Reply
Shro0m
Posts: 46
Joined: Tue Nov 22, 2011 7:34 am

Re: new pvst beta (updated 06-Mar-2012)

Post by Shro0m »

I cant quote my quote of a quote... or something.. So new post :)
Regarding the problem with buzz crashing while loading bmx's containing "asio in", Ive done some testing.
It seems the problem lies with pvst post b19. The "audio-in" crash occurs with both b21 & b22. i couldn't find b20, so i didn't get a chance to check that one. I've tested some different buzz builds, but that didn't seem to affect anything. I don't know if this is on my system only?
Anyway, I've been analyzing process monitor logs, but i can't seem to find the problem here. Polac drivers loads with success.
I've uploaded the dump in case you want to take a look at it: http://box.retrofox.dk/t/Logfile_polac_buzz_crash.xls

mute
Posts: 374
Joined: Mon Nov 21, 2011 8:30 pm

Re: new pvst beta (updated 28-Jan-2012)

Post by mute »

mcbpete wrote:
strobotone wrote:had the same issue with drumatic 3 too.
disabling multithreading for this vst solved the issue most of the time.
however, when loading a bmx containing the machine the issue came up again.
i found only one workaround:
1) create a second instance of drumatic in the same bmx
2) save and reload the preset of the first drumatic if the burst still occurs.
Confirmed - and I'll get a noiseburst 90% of the time on this example .bmx even if multithreading is disabled (erm, obviously needs Drumatic 3!) - http://www.ilovecubus.co.uk/pete/drumatic.bmx (WARNING - The burst is insane if it hits, please turn down headphones/speakers)

EDIT: Not quite sure why the file is over a meg, there's no wavetable and <10 machines :?
disabling multithreading does nothing for me, drumatic3's kick (c-3) does this everytime i attempt to use it. i've tried every setting under the sun too.

polac
Posts: 267
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 06-Mar-2012)

Post by polac »

Thanks for this example, however no noise bursts etc. for me with this song, and I also had the additional machines installed here. I tried various audio drivers and samplerate settings with multithreading on/off but no result.

User avatar
mcbpete
Posts: 318
Joined: Tue Nov 22, 2011 9:45 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by mcbpete »

Weird th0ke is able to get the burst with the example too ( viewtopic.php?p=3561#p3561 - N.B. He got the two example files I uploaded mixed up, so that's why he refers to not being able to see a matilde). N.B. Sometimes it takes about 20 seconds to happen, sometimes it's instant - as it's pseudo-randomly Peer controlled the troublesome note may not make an appearance for a little bit.

For reference I'm using Polac ASIO audio driver @ 44.1 KHz

mute
Posts: 374
Joined: Mon Nov 21, 2011 8:30 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by mute »

Maybe it has something to do with 64bit or different processors? I'm on a AMD 64bit running win7 64, running buzz 32bit

Ran fine in b16.. but I haven't gone back to check that version again

User avatar
mcbpete
Posts: 318
Joined: Tue Nov 22, 2011 9:45 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by mcbpete »

mute wrote:Maybe it has something to do with 64bit or different processors? I'm on a AMD 64bit running win7 64, running buzz 32bit
Mmm possibly, I'm on an Intel i7 (Sandy bridge) 64bit running Windows 7 (with 32 bit Buzz). Should I be running the Buzz AVX builds, or is/was this just for test purposes by Oskari ?

User avatar
UNZ
Posts: 697
Joined: Mon Nov 21, 2011 9:42 pm
Contact:

Re: new pvst beta (updated 06-Mar-2012)

Post by UNZ »

mcbpete wrote:
mute wrote:Maybe it has something to do with 64bit or different processors? I'm on a AMD 64bit running win7 64, running buzz 32bit
Mmm possibly, I'm on an Intel i7 (Sandy bridge) 64bit running Windows 7 (with 32 bit Buzz). Should I be running the Buzz AVX builds, or is/was this just for test purposes by Oskari ?
i use the avx build, never tested the speed gain / no idea how much it uses avx really, but it works flawlessly.

oskari
Site Admin
Posts: 281
Joined: Mon Nov 21, 2011 2:04 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by oskari »

Note that there hasn't been an avx build since 1458.

mute
Posts: 374
Joined: Mon Nov 21, 2011 8:30 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by mute »

2 ASIO Out machines can have different outputs and work simultaneously, but if I reload the .bmx with 2 or more ASIO Out machines present, Buzz crashes. Also, an ASIO Out machine completely disables the Master output. I know this was designed usage awhile ago, but thought there were some changes.

User avatar
mcbpete
Posts: 318
Joined: Tue Nov 22, 2011 9:45 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by mcbpete »

Aah glad it's not just me - I was starting to think my Buzz just didn't like my new laptop. I've begun to use the two ASIO outs now as I'm starting to learn surround sound composition, I use one ASIO machine for the front two channels and another for the back two - not sure if there's a better way of doing it but as I say I'm just beginning to use Buzz this way.

mute
Posts: 374
Joined: Mon Nov 21, 2011 8:30 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by mute »

The ASIO machines were changed awhile ago so that you only use 1, then select the outputs with the multi-io plug. Only one machine would perform output. Previously (ASIO Stereo Out/ASIO Stereo In, etc) you could add as many machines as possible and mix as needed, with the Master out also being assignable in prefs. I complained a little bit awhile ago (once the driver completely stopped working with the old asio machines and I realized how the new ones behave) so polac made it so we can have multiple asio machines again, but it appears it still needs some work.

As to why I personally prefer the 'old' way of working -- I use 10 ASIO Outputs, 1/2 is the dry send+mixed output (Master) the rest are routed to what are mostly wet-only effect setups, then run into my h/w mixer and back to my computer. I may have 1 chain connected to 3 or 4 different ASIO Outputs at a time, which does not work well with the 1 machine mindset or for overall mix control.

I do like that only 2 machines exist (instead of 4) and that they CAN do multiple channels on one machine - would make the returns much easier/cleaner machine view wise. It would seem best IMO, to combine both worlds (pasio1.2 and the new features) and also still allow Master output..

polac
Posts: 267
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 06-Mar-2012)

Post by polac »

mute wrote:2 ASIO Out machines can have different outputs and work simultaneously, but if I reload the .bmx with 2 or more ASIO Out machines present, Buzz crashes. Also, an ASIO Out machine completely disables the Master output. I know this was designed usage awhile ago, but thought there were some changes.
I think I found the bug now, it's somehow related to the renaming of a machine in CMachineInterface::Init(). Btw. the asio out machine is so to say an equivalent to the newer audio out machine, it's olny there for compatibility purpose. It would also work with wdm/mme drivers etc, it also changes it's names too on driver change.

User avatar
aKa
Posts: 3
Joined: Thu Dec 01, 2011 1:19 pm
Location: Vienna
Contact:

Re: new pvst beta (updated 06-Mar-2012)

Post by aKa »

8-)

Polac, my man. Nice to see you working on VST-Stuff.
Food for the junkies. Kudos.

User avatar
mcbpete
Posts: 318
Joined: Tue Nov 22, 2011 9:45 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by mcbpete »

Shro0m wrote:I cant quote my quote of a quote... or something.. So new post :)
Regarding the problem with buzz crashing while loading bmx's containing "asio in", Ive done some testing.
It seems the problem lies with pvst post b19. The "audio-in" crash occurs with both b21 & b22. i couldn't find b20, so i didn't get a chance to check that one. I've tested some different buzz builds, but that didn't seem to affect anything. I don't know if this is on my system only?
Yep I get it too, just a simple .bmx with nothing but an audio-in connected to the master (no patterns or other machines). Saving that basic setup, then reloading gives an instant crash on my system (Polac b22, i7, 64 bit Win 7, running 32 bit Buzz using both the regular and avx builds).

Ditto with any ASIO In from old bmxs I've saved - Instant Buzz crash. So any audio input is a no go on my machine at the moment if I want to save and reload the project at a later date.

domtron
Posts: 84
Joined: Tue Nov 22, 2011 5:18 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by domtron »

atm. start a session with wasapi,then switch to asio.

polac
Posts: 267
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 06-Mar-2012)

Post by polac »

mcbpete wrote:
Shro0m wrote:I cant quote my quote of a quote... or something.. So new post :)
Regarding the problem with buzz crashing while loading bmx's containing "asio in", Ive done some testing.
It seems the problem lies with pvst post b19. The "audio-in" crash occurs with both b21 & b22. i couldn't find b20, so i didn't get a chance to check that one. I've tested some different buzz builds, but that didn't seem to affect anything. I don't know if this is on my system only?
Yep I get it too, just a simple .bmx with nothing but an audio-in connected to the master (no patterns or other machines). Saving that basic setup, then reloading gives an instant crash on my system (Polac b22, i7, 64 bit Win 7, running 32 bit Buzz using both the regular and avx builds).

Ditto with any ASIO In from old bmxs I've saved - Instant Buzz crash. So any audio input is a no go on my machine at the moment if I want to save and reload the project at a later date.
Yes it also happens with the inputs, as i said it's related to renaming a machine while loading a song, it's fixed with the next beta then.

mute
Posts: 374
Joined: Mon Nov 21, 2011 8:30 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by mute »

polac, you're a champ man. hope we're not wearing you out ;] i don't know what i'd do without you personally.

everyone should think about clicking on that donate button @ http://www.xlutop.com/buzz/ every once and awhile, i just did ;]

User avatar
mcbpete
Posts: 318
Joined: Tue Nov 22, 2011 9:45 pm

Re: new pvst beta (updated 06-Mar-2012)

Post by mcbpete »

Aye absolutely, the work is very much appreciated. A donation should now be heading your way from me too ...

User avatar
mcbpete
Posts: 318
Joined: Tue Nov 22, 2011 9:45 pm

Re: new pvst beta (updated 09-Apr-2012)

Post by mcbpete »

It works ! :D

double07
Posts: 36
Joined: Thu Nov 24, 2011 6:17 am
Location: Australia

Re: new pvst beta (updated 06-Mar-2012)

Post by double07 »

mute wrote:everyone should think about clicking on that donate button @ http://www.xlutop.com/buzz/ every once and awhile, i just did ;]
Yeah good call, donated :)

Post Reply