Buzz 1503 *86 version not workin on 64bitWIN7

Post Reply
imiafan
Posts: 12
Joined: Mon May 29, 2017 9:03 pm

Buzz 1503 *86 version not workin on 64bitWIN7

Post by imiafan »

hello buzzers
any advise on this one?
I installed Buzz 1503.
The 32bit version not starting at all. No error message. Nothing. What should I check?

64bit version seems to work but most of the old machine are not usable. When trying to open my old BMX files - crashes.

I need to make the 32b version working. Please help.
Last edited by imiafan on Thu Jun 01, 2017 8:47 am, edited 3 times in total.

domtron
Posts: 87
Joined: Tue Nov 22, 2011 5:18 pm

Re: Buzz 1503 on WIN7 Pro 64 not starting at all

Post by domtron »

Have you tried to install it with admin rights (right mouse click).Did you install it in program files ( for 32 bit x86)?

imiafan
Posts: 12
Joined: Mon May 29, 2017 9:03 pm

Re: Buzz 1503 on WIN7 Pro 64 not starting at all

Post by imiafan »

Yes. Yes. I just reinstalled again now and same behaviour - Buzz not starting at all.

btw after reinstall I see on my Desktop also Buzz (AVX) icon which is linked to non existing exe file.
and also I had installed previously the 64bit 1503 Buzz too and run it, but unistalled it.

Please help to make my Buzz work again.
Thanks

domtron
Posts: 87
Joined: Tue Nov 22, 2011 5:18 pm

Re: Buzz 1503 on WIN7 Pro 64 not starting at all

Post by domtron »

The AVX must be an old installer.Why did you uninstall 1503 x64? You can install 1503 x86.That are the installer to use and they install but you can't start Buzz?
Try to grab the Polac Vst files and install them first,that's what i'm always doing, i never had a problem to start Buzz.

viewtopic.php?f=3&t=7


Buzz requires Net Framework 4 and if there is still a problem you can try a application named "dependency walker" to see if there is anything else missing on your OS.

imiafan
Posts: 12
Joined: Mon May 29, 2017 9:03 pm

Re: Buzz 1503 on WIN7 Pro 64 not starting at all

Post by imiafan »

Thanks for your help.
I used the old Buzz since 2000 till February this year when I chnaged my music computer to 64.
I installed the new BUzz and it was working fine but I had no time to use it and produce music since then.
Now I got these problems.
-----

I have Net 4.

After reading Polac's site. I installed Polac VST prior to Buzz.
I am able to start Buzz 64 now. I copied all the gear from Buzz_Complete_BigPack_Jun-2011.rar to its gear folder.
I deleted the blacklisted ones, but when I start the Buzz I see in Gear folder just the basic Jeskola gear.
What do I miss again?
I downaloaded Other Machines too, but almost all of them are unusable in Buzz 64.

Buzz32 does not start.
I run Dependency Walker on its EXE and got the following errors with missing
API-MS-WIN-CORE-WINRT-ERROR-L1-1-0.DLL
API-MS-WIN-CORE-WINRT-L1-1-0.DLL
API-MS-WIN-CORE-WINRT-ROBUFFER-L1-1-0.DLL
API-MS-WIN-CORE-WINRT-STRING-L1-1-0.DLL
DCOMP.DLL
IESHIMS.DLL

and
Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.
Error: Modules with different CPU types were found.
Warning: At least one delay-load dependency module was not found.
Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

Actually I get same error from it on Buzz64 exe file which is working but not loading all gear from its folder.

Can I use Buzz64 instead from now? I need to open my old Buzz files too so I need some older Machines and Effects from the BigPack.

I need very much to make Buzz *86 running to get back my Buzz history. Please advise.

imiafan
Posts: 12
Joined: Mon May 29, 2017 9:03 pm

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by imiafan »

ok I reinstalled 1503 *86 as administrator again.
I have basic Jeskola generators and effects only.
Polac VST installed too as explained on his web.

Dependency Walker on Buzz.exe - screen shot attached.

Please advise what should I look in to solve this and make Buzz run.
2017-06-02 08_40_17-Dependency Walker - [buzz].png
2017-06-02 08_40_17-Dependency Walker - [buzz].png (159.35 KiB) Viewed 3293 times

domtron
Posts: 87
Joined: Tue Nov 22, 2011 5:18 pm

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by domtron »

I'm not a coder but when i read "Api-Ms" it looks like it has something to do with Windows and not with Buzz.Do you have a spare drive to install Windows? Why not Windows 10,it is much faster to install than Win 7 and there you can test if Buzz is working on your system.
If there is something broken with your Win 7 installation you can use the scannow command (Google how to do it) and to try to repair it.

imiafan
Posts: 12
Joined: Mon May 29, 2017 9:03 pm

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by imiafan »

thanks for your check on my problem

I scanned - nothing found
2017-06-02 13_56_36-Administrator_ Command Prompt.png
2017-06-02 13_56_36-Administrator_ Command Prompt.png (5.41 KiB) Viewed 3280 times
I read somewhere that the Dependency Walker may generate non existent error for new Windows.

polac
Posts: 319
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by polac »

Polac VST installed too as explained on his web.
The infos on my website regarding installing the loader are obsolete. Just unpack the zip into the buzz folder and all should be installed properly.

imiafan
Posts: 12
Joined: Mon May 29, 2017 9:03 pm

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by imiafan »

polac wrote:
Polac VST installed too as explained on his web.
The infos on my website regarding installing the loader are obsolete. Just unpack the zip into the buzz folder and all should be installed properly.
yes. Thats what I did.
Buzz x86 not possible to start for me.
I have no idea why.

At least 64 version works, but I am trying figure out how to make it working with older machines too.

User avatar
UNZ
Posts: 746
Joined: Mon Nov 21, 2011 9:42 pm
Contact:

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by UNZ »

imiafan wrote:ok I reinstalled 1503 *86 as administrator again.
I have basic Jeskola generators and effects only.
Polac VST installed too as explained on his web.

Dependency Walker on Buzz.exe - screen shot attached.

Please advise what should I look in to solve this and make Buzz run.
2017-06-02 08_40_17-Dependency Walker - [buzz].png

you can ignore the ms-api-wincore errors (this happens on every machine, not a problem), what you are looking for is if there are msvcrt (any version) missing, but that has to do with machines, not buzz itself, and you need to scan the machine dll, not the buzz exe. Buzz comes bundled with the right dependencies it needs.
for machine dlls, if you see missing msvcr entries, install msvcrt (runtime distributables, 2008 and newer ones).
for a lot of old machines you'll also need the very old msvcr70.dll and msvcr71.dll in your buzz root.
i zipped those up here: http://unz.obscure.ch:88/msvcr71.zip

also you really have to get the x86 version to work, the x64 one is really experimental (as it says). try deleting the all registry entries for buzz and see if it starts up then. \HKEY_CURRENT_USER\Software\Jeskola\Buzz delete this whole tree.

for pvst, make sure you don't have any old version lying around in the wrong directories (like efx in gens or vice versa).

imiafan
Posts: 12
Joined: Mon May 29, 2017 9:03 pm

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by imiafan »

thanks for your check on my problems

- all msvcrs installed
2017-06-09 23_28_55-Total Commander (x64) 9.0a - NOT REGISTERED.png
2017-06-09 23_28_55-Total Commander (x64) 9.0a - NOT REGISTERED.png (19.01 KiB) Viewed 3194 times
- registry \HKEY_CURRENT_USER\Software\Jeskola\Buzz
deleted

- Dependency run on Machines.dll - no different error as on buzz.exe previously

- pvst should be ok

Buzz x86 not starting yet

polac
Posts: 319
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by polac »

Did you also try a clean Buzz without all buzzmachines installed? If it works you could try to add your machines step by step.

imiafan
Posts: 12
Joined: Mon May 29, 2017 9:03 pm

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by imiafan »

for x86 I have only the basic Jeskola gear - nothing else - MDB folder renamed now, so its not loaded (I tried in x64)
btw I installed also the 1502, but same as 1503 - not starting
2017-06-10 12_45_28-Total Commander (x64) 9.0a - NOT REGISTERED.png
2017-06-10 12_45_28-Total Commander (x64) 9.0a - NOT REGISTERED.png (13.08 KiB) Viewed 3182 times
2017-06-10 12_46_23-Total Commander (x64) 9.0a - NOT REGISTERED.png
2017-06-10 12_46_23-Total Commander (x64) 9.0a - NOT REGISTERED.png (11.21 KiB) Viewed 3182 times

User avatar
UNZ
Posts: 746
Joined: Mon Nov 21, 2011 9:42 pm
Contact:

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by UNZ »

imiafan wrote: - Dependency run on Machines.dll - no different error as on buzz.exe previously
not machines.dll, what i ment is if a particular machine doesn't work (like say matilde) then you check matilde.dll. but that shouldnt prevent buzz from starting so your issue must be something else...

imiafan
Posts: 12
Joined: Mon May 29, 2017 9:03 pm

Re: Buzz 1503 *86 version not workin on 64bitWIN7

Post by imiafan »

I agree. After start I saw in Task manager buzz.exe for 1 sec running and then gone.

Something with WIN 7 and administrator installed program which is in this case x86 Buzz?

Post Reply