[SOLVED] Loading BMX: The missing pattern/machines problem

Post Reply
User avatar
HerrFornit
Posts: 250
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

[SOLVED] Loading BMX: The missing pattern/machines problem

Post by HerrFornit »

Hi,

I have (still) the problem, that I can't see the pattern (no tracks/instruments, no sequence, no pattern contents) of some downloaded songs and can't hear sound.

Now I have today discovered that there is a correlation with the "missing machines" problem:
After loading a bmx file by double-clicking in the windows file explorer, I have a lot of missing machines in the machines view (s. picture, only the 11-parrot wansn't really there). Usually I saved and reloaded the bmx via the recent file list of buzz, and they are shown. Now I discovered today with a downloaded song from thOke (https://www.buzztunes.org/music/thoke/buzzboards thanx ! s. below) that the patterns are visible when the machines are missing.

After saving the song and reloading the song, the machines are there - but the patterns are gone !
So either the patterns or machines are missing.

What I have done so far without success:
reinstalled the MS visual c++ 2015, instead of the 2017, checked the visual c++ versions, correct.
reinstalled buzz.
tried different installations of the patternxp, with no substitution, substitution of the delivered pxp and parallel installation of both.
Deactivated UAC. Full Admin rights.
Copied msvcr70.dll and msvcr71.dll in Buzz root.

I use Win10x64 pro, 1809.

Thanx for replies and hints.
Missing machines.jpg
Missing machines.jpg (54.68 KiB) Viewed 1447 times
Found Machines.jpg
Found Machines.jpg (48.47 KiB) Viewed 1428 times
Setup by theOke
Last edited by HerrFornit on Fri Feb 15, 2019 12:11 pm, edited 8 times in total.

User avatar
HerrFornit
Posts: 250
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: Loading BMX: The missing pattern/machines problem

Post by HerrFornit »

The missing machines in the picture are from the "more machines" directory, as I can see.

So in part a problem of machine incompatibility? Do I have to adjust the gear.xml?

User avatar
thOke
Posts: 316
Joined: Thu Nov 24, 2011 7:14 am

Re: Loading BMX: The missing pattern/machines problem

Post by thOke »

Hmmmm... my guess is, that you somehow mixed up the effects and generators in your gear directory.
In your "missing machines" screenshot, some machines are connected to the master, that actually should be assigned to a machine, not connected to anything (LD auxsend, PeerChord, Split).
PeerScale on the other isn't, so that might be in the correct folder.

Here is the file with packed machines. Probably that might help:
https://app.box.com/s/w0chi4hs94owg0awle712p88ie5fig8r

User avatar
HerrFornit
Posts: 250
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: Loading BMX: The missing pattern/machines problem

Post by HerrFornit »

Thanx thOke, you did a good analysis! :dance:

Except the mixIO machine, I copied all your machines into my directories. Some machines look really different. It's a big mess with buzz machines and different versions (!?).
ThOkes's Machines.jpg
ThOkes's Machines.jpg (42.91 KiB) Viewed 1415 times

User avatar
thOke
Posts: 316
Joined: Thu Nov 24, 2011 7:14 am

Re: Loading BMX: The missing pattern/machines problem

Post by thOke »

HerrFornit wrote:Thanx thOke, you did a good analysis! :dance:

Except the mixIO machine, I copied all your machines into my directories. Some machines look really different. It's a big mess with buzz machines and different versions (!?).
And does it play now?!
I made a "skinned version" of some machines long ago - that's why they are looking different,
but that doesn't have an impact on functionality. You can replace them with the originals, if you don't want those skins.

But it is very important, that they are placed in the correct folders (effect or generator), and that they are not present in both! :ugeek:

User avatar
HerrFornit
Posts: 250
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: Loading BMX: The missing pattern/machines problem

Post by HerrFornit »

Aah, yes sorry. It' s playing. Sounds good! Does this mean that the machines are not present in both directories? I didn't compare it in detail because it works.
I will check it out these days more profoundly. Unfortunaltely my speakers are not present in the moment.
Nice skins! like it.

User avatar
HerrFornit
Posts: 250
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: Loading BMX: The missing pattern/machines problem

Post by HerrFornit »

hi again,

ok. I compared my effect vs generators directories in the buzz installation folder. I killed 2 .fixed dll and renamed the fixed to .dll. (inp and 2ndLoopjumphack).
No doubles found.

But, in the "more machines" folder (documents\buzz\generators) I found at once the 2ndLoopJumpHack, too. Didn't check the rest yet.
OK, I renamed for test purposes this folder to buzz_ and your "ProgBluesImprovMagic.bmx" played sound and the 2 patterns are still there after save and reload. Of course,a lot of missing machines, because the folder is renamed.

So my thesis is that this "more machines" folder is a problem, by doubled generators in comparison to the installation folder machines.

Isn't it possible to copy/move the "more machines" folder in documents\buzz to the installation folder? and skip all doubles, so only one installation location is used and less confusion occurrs?
What do you think?

User avatar
thOke
Posts: 316
Joined: Thu Nov 24, 2011 7:14 am

Re: Loading BMX: The missing pattern/machines problem

Post by thOke »

HerrFornit wrote: So my thesis is that this "more machines" folder is a problem, by doubled generators in comparison to the installation folder machines.

Isn't it possible to copy/move the "more machines" folder in documents\buzz to the installation folder? and skip all doubles, so only one installation location is used and less confusion occurrs?
What do you think?
Yes, that might be a problem. I don't have this "more machines" folder. All machines are in Buzz/Gear/Effects(or)Generators.

User avatar
HerrFornit
Posts: 250
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: Loading BMX: The missing pattern/machines problem

Post by HerrFornit »

thanks. Ok, I did it.

works better now, but still machines are missed.

In the earlier days there have been machine packs. Can you download a pack anywhere?

User avatar
HerrFornit
Posts: 250
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: Loading BMX: The missing pattern/machines problem

Post by HerrFornit »

ok. Still got problems.
Restored the directories without the"more machines".
copied step by step missing machines.
Now your blues impro works ! Fine - got a better idea for IXix's Magix machine now. "Randomly" played set or so. Great!

OK compared the "more machines" effect vs generator folder, is this the problem ? (original extracted out of the zip file)
Doubles.jpg
Doubles.jpg (129.16 KiB) Viewed 1338 times


User avatar
HerrFornit
Posts: 250
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: Loading BMX: The missing pattern/machines problem

Post by HerrFornit »

ok.
I have learned something:

Do not install the "more machines", rather download and move them to an other location on your drive. Install machines only if needed and copy them to the installation gear directories. Get the needed machines out of the big machines depot, made out of the "more machines" and downloads .


Great. I can finally listen first time "live" to already downloaded songs: magmavanders "trackers delight" and hamsters "SupperRiff" song ! :)

Thank you very much.

boombaxx
Posts: 267
Joined: Tue Dec 06, 2011 6:54 pm

Re: [SOLVED] Loading BMX: The missing pattern/machines probl

Post by boombaxx »

Hi i am having the same problem even if replace the machine like for like the replacement comes up as missing as well when reloaded. PVSTi is even coming up as missing. I have all the machines in my main buzz directory and all the machines in the songs are present in the directory but buzz keeps insisting there missing. Some load some don't but pvsti not loading i cannot see how that works

User avatar
HerrFornit
Posts: 250
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: [SOLVED] Loading BMX: The missing pattern/machines probl

Post by HerrFornit »

boombaxx wrote:Hi i am having the same problem even if replace the machine like for like the replacement comes up as missing as well when reloaded. PVSTi is even coming up as missing. I have all the machines in my main buzz directory and all the machines in the songs are present in the directory but buzz keeps insisting there missing. Some load some don't but pvsti not loading i cannot see how that works
Hi boombaxx,

did you try building up the machines step by step. Let's say starting with a problematic song, installing only the needed machines/plugins ?

Post Reply