Page 1 of 1

Buzz on Linux in 2020

Posted: Fri Feb 21, 2020 6:55 pm
by mridlen
I posted this in the Buzzers facebook group, but I figured I should post here too now that the board is working again.

I was able to get the current build of Jeskola Buzz running on Linux... with sound output. This was done on Fedora Linux, but should work on most Linux distros.

Install wine
Install playonlinux and run it
Download Buzz (x86) and install it with playonlinux
Set it up as 32-bit Windows
include library dotnet40

That's pretty much it. Just wanted to share the process with anyone that is interested. I have no idea how well this works long term, or with VSTs, but it at least loads and plays sound.

Someone who knows Windows libraries might be able to shed some light on why dotnet40 does not install on a 64 bit "windows" in Linux. Is there a different library that will do the trick to get Buzz working? I don't really know the library requirements

Re: Buzz on Linux in 2020

Posted: Sat Feb 22, 2020 12:32 pm
by mik82
Thank you! I'll have to try this as have been trying to use Buzz on Linux for years.

Re: Buzz on Linux in 2020

Posted: Sun Feb 23, 2020 6:46 pm
by mridlen
I will say I'm getting some really bad visual glitches that make it very hard to use it efficiently. Again, hopefully someone with more persistence can come though and refine this procedure.

Re: Buzz on Linux in 2020

Posted: Mon Feb 24, 2020 11:34 am
by mcbpete
Have you tried Winetricks -
Might help with all the WPF stuff that runs the gui (try maybe downloading the 'windowscodecs' and 'dotnet*' packages)

Re: Buzz on Linux in 2020

Posted: Thu Dec 17, 2020 11:57 pm
by commadore65
By no means working, but did manage to get it to open on manjaro using play on linux. I was a bit drunk when I manged to get it to open after a long time of installing different components to the virtual drive (loads of the ms ones, vbrun, vcrun, dotnet45, msxml, corefonts and a bunch of others) sadly didn't keep a log. Tried it again from memory but failed so not sure of the list.

I also managed to get it to play some sound (loading templates), but it is an instant crash adding machines through right click or type menu. I'm not sure what dependency is missing. If you open the templates it can load machines which work, suggesting the template loading doesn't use the same process/dependency.

If anyone with more patience, Linux prowess and gumption than me wants to investigate issues here's a zip of my play on linux virtual drive - ... sp=sharing. Copy it into the folder with other virtual drives, install buzz on that drive from installer via play on linux.


Re: Buzz on Linux in 2020

Posted: Fri Dec 18, 2020 2:16 am
by commadore65
I should probably add wine config in playonlinux seems to work with win7 or 10. 7 will probably be better I guess, seems to be broken equally atm :P.

Re: Buzz on Linux in 2020

Posted: Sun Dec 20, 2020 2:12 pm
by mik82
I've had a try using wine, and also a trial of Codeweavers crossover. I installed dotnet40 into a 64 bit Windows 10 bottle, then Buzz.

Similar in both - I can get Buzz to run but it's very slow and visually glitchy. I can add a machine, but as soon as I try and add a pattern it crashes.

Certainly this is a lot further than I've got previously.