EasyRec

User avatar
HerrFornit
Posts: 273
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: EasyRec

Post by HerrFornit »

Hi WDE,

I tried the first test setup a bit further and found this (s. picture). The yellow line does not extend to Audio 06 (brighter background, too). I put the Audio 06 by drag n drop into AudioBlock. Its a sample of the new compiled Loop recorder. The other 5 are automatically recorded first with EasyRec. Does loop recorder cut the silence at the beginning? The silence at the beginning of Audio 02 (green) is correct this time. It should be the same in Audio 06. Or do I use loop recorder in a wrong way?
Edit: Forget first part with the yellow line, forget to add a track :oops: So no bug of course!
EDIT: Probably threshold detection in LoopRec for recording start, hm then it cant be used to compare to EasyRec?

EDIT2: I think I have found the reason for the extra 2 ms (or so) silence! I remembered a recent dialogue with temporalsounds here in the forum where I discovered that I have the MachineDelayCompensation in the settings of BUZZ on "true", switching it to false" removes a little bit of the silence !! Don't you need it?
EasyRecAudioBlockMultichannel LoopRec.jpg
EasyRecAudioBlockMultichannel LoopRec.jpg (96.94 KiB) Viewed 271 times
Last edited by HerrFornit on Sun Aug 09, 2020 9:55 am, edited 2 times in total.

wde
Posts: 168
Joined: Sun Jan 08, 2012 9:28 am

Re: EasyRec

Post by wde »

HerrFornit wrote:
Sat Aug 01, 2020 6:08 pm
Does loop recorder cut the silence at the beginning?
LR starts to record when it detects sound. EasyRec records immediately.
HerrFornit wrote:
Sat Aug 01, 2020 6:08 pm
Don't you need it?
Yes, if you want to sync all machines precisely. This means that if a machine introduces latency/delay and you have the MachineDelayCompensation enabled then all machines are delayed the same amount. This is why you get the x ms silence at the beginning. You might disable it if the delay does not hurt the composition.

To improve workflow, I added an option that enables LR to render directly to Wavetable.
Jeskola Loop Recorder WT.zip
(10.84 KiB) Downloaded 9 times

User avatar
HerrFornit
Posts: 273
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: EasyRec

Post by HerrFornit »

Ok, thanx.
But, recording an instrument, e.g. AGML see picture waveforms, results in an out of sync playing when MachineDelayCompensation is true (green waveform, yellow false). So I have then out of sync problem in playback situations, although delay should be compensated ?!

To be in the example: recording a sample into AudioBlock and playback with the original instrument simultaneously results in an out of sync playing when MDC is true, not so when it is false. That's a problem when recording live with playback, e.g. recording a vocal. (set it makes sense to use MDC, but as you said it makes sense).

Am I wrong?
AudioblockMachineDelayCompensation.jpg
AudioblockMachineDelayCompensation.jpg (14.79 KiB) Viewed 52 times

Post Reply