AudioBlock

User avatar
IXix
Posts: 895
Joined: Wed Nov 23, 2011 3:24 pm

Re: AudioBlock

Post by IXix »

wde wrote:
Sun Oct 11, 2020 11:12 am
Updated but code is very messy. You have been warned ;)
Hehe, thanks! :D

User avatar
HerrFornit
Posts: 305
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: AudioBlock

Post by HerrFornit »

tried to add volume curve points in a certain zoomfactor resulting in adding points at the left visible border. not movable.
AddPointWindow.jpg
AddPointWindow.jpg (41.72 KiB) Viewed 383 times
after resizing to full length of sample trying to move points ended in this: also mscorlib error out of range negativ values... when touching one of the points
AddPointWindow2.jpg
AddPointWindow2.jpg (38.21 KiB) Viewed 383 times
AddPointWindowMScorlib.jpg
AddPointWindowMScorlib.jpg (100.96 KiB) Viewed 382 times

wde
Posts: 213
Joined: Sun Jan 08, 2012 9:28 am

Re: AudioBlock

Post by wde »

1.2.2.6
  • Fixes

User avatar
HerrFornit
Posts: 305
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: AudioBlock

Post by HerrFornit »

thank you! recent bug seems to be fixed. 8-)

User avatar
HerrFornit
Posts: 305
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: AudioBlock

Post by HerrFornit »

sorry, the "snapping the points to left margin" is not gone. but no crash so far.

I use the same wavfile for several patterns and moving the wave position slider and wave length slider for adding volume curve, then it happens when I want or move a point or add a new one -snap!

EDIT: OK, I am a bit confused about the vertical lines, probably no bug, just snapped to next beat out of sight :oops:

wde
Posts: 213
Joined: Sun Jan 08, 2012 9:28 am

Re: AudioBlock

Post by wde »

HerrFornit wrote:
Sun Nov 08, 2020 10:46 pm
EDIT: OK, I am a bit confused about the vertical lines, probably no bug, just snapped to next beat out of sight :oops:
Yeah, I couldn't reproduce it.

Updated: Small fixes and improvements.

Post Reply