Adventures in 4K

Post Reply
User avatar
mcbpete
Posts: 327
Joined: Tue Nov 22, 2011 9:45 pm

Adventures in 4K

Post by mcbpete »

After a decade of intense use I've finally got round retiring my humble lappy and get a new one to hopefully last me as long. It's got the new fangled Geforce RTX 2080 graphics card in it and natively runs everything in 4k. So far so snazzy - However day two of migrating everything over from my old machine and of course Buzz takes highest priority!

All started so promising with the Machine View working perfectly, including the parameter views and all menus:

Image

Next we've the pattern view, everything at the top (the newer sequencer view) is a-ok but the main editor is a bit ... yikes:

Image

And finally the Sequence View, which despite my eyesight normally being pretty good ... it's a little, well small is not the word :) :

Image

The system scaling is on 200% so essentially all the Windows UI elements are 'stretched' to effectively HD resolution (1920x1080) but I'm guessing as neither the pattern view or sequencer view uses WPF then it's not scaling things as required ?

Any hints or successes in getting Buzz to work fully in 4k resolutions ?

User avatar
UNZ
Posts: 747
Joined: Mon Nov 21, 2011 9:42 pm
Contact:

Re: Adventures in 4K

Post by UNZ »

set scaling to 100%... hope you have a big enough screen hehe

User avatar
mcbpete
Posts: 327
Joined: Tue Nov 22, 2011 9:45 pm

Re: Adventures in 4K

Post by mcbpete »

Alas it's a 17 inch laptop ... looks like I'm gonna have to up my prescription :lol:

Image

I might just run my laptop at 1920x1080 ... so few apps seems to be 4k compatible at the moment

User avatar
mcbpete
Posts: 327
Joined: Tue Nov 22, 2011 9:45 pm

Re: Adventures in 4K

Post by mcbpete »

Aha, looks like I've found a fix.... For anyone else having issues running Buzz at such a resolution:

Find the buzz.exe in explorer
Right click -> Properties
Go to the Compatibility tab
Click 'Change settings to for all users' (right at the bottom)
Click 'Change high DPI settings'
Tick both Program DPI and High DPI scaling override
On the 'High DPI scaling override' dropdown choose 'System' (not 'System (Enhanced)' as that messes up the WPF parts of the UI)

Everything should now be properly scaled and readable !

Post Reply