problems with Buzz x64, starting build 1454

Post Reply
sfMan
Posts: 11
Joined: Fri Nov 25, 2011 3:48 pm

problems with Buzz x64, starting build 1454

Post by sfMan »

Hi!
When starting build x64_1454 or later i got 3 error windows:

-----------------------------------------------------------------------------
C:\Program Files\Jeskola\Buzz_x64\Themes\Default\ToolBar.xaml
-----------------------------------------------------------------------------
'Failed to create a 'Command' from the text 'l:ToolBarVM.NewFileCommand'.' Line number '102' and line position '29'.


--------------------------------------------------------------------------------------------------
C:\Program Files\Jeskola\Buzz_x64\Themes\Default\MachineView/MachineView.xaml
--------------------------------------------------------------------------------------------------
Provide value on 'System.Windows.StaticResourceExtension' threw an exception.
at System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
at System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
at System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
at BuzzGUI.MachineView.MachineView..ctor(IBuzz buzz, ResourceDictionary rd)
at BuzzGUI.MVGUI.Load(MVGUI* , SByte* path, IMachineGraph mg, IBuzz ibuzz)


---------------------------------------------------------------------------------------------------------
C:\Program Files\Jeskola\Buzz_x64\Themes\Default\SequenceEditor/SequenceEditor.xaml
---------------------------------------------------------------------------------------------------------
Cannot find resource named 'SeqEdTimelineBackgroundSolidColorBrush'. Resource names are case sensitive.
at System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
at System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
at System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
at BuzzGUI.SequenceEditor.SequenceEditor..ctor(IBuzz buzz, ResourceDictionary rd)
at BuzzGUI.SeqEdGUI.Load(SeqEdGUI* , SByte* path, ISong song, IBuzz ibuzz)



Buzz opens but it is only empty window with title bar. No menus, no application workspace
32-bit version of Buzz working normally.
I'm using Win7x64, have all .NET Frameworks and updates.
It seems that something wrong or missing in 64bit version. Something with Default theme maybe.
Last edited by sfMan on Thu Feb 23, 2012 2:46 am, edited 2 times in total.

User avatar
strobotone
Posts: 297
Joined: Wed Nov 23, 2011 2:59 pm
Location: berlin
Contact:

Re: problems with Buzz x64, starting build 1454

Post by strobotone »

i wonder if the default theme is the same as in the 32bit setup.

Dean
Posts: 89
Joined: Fri Feb 10, 2012 6:11 pm

Re: problems with Buzz x64, starting build 1454

Post by Dean »

Did you notice the little notice on jeskola page which saids the x86 version is "recommended for both 32-bit and 64-bit Windows"?
edit: actually, maybe you know what you're doin', as you suggest you are still using the 32-bit version (which means you didn't install them in the same
folder)...
I've never used the x64 version myself, so can't help you, sorry.

sfMan
Posts: 11
Joined: Fri Nov 25, 2011 3:48 pm

Re: problems with Buzz x64, starting build 1454

Post by sfMan »

Dean wrote:Did you notice the little notice on jeskola page which saids the x86 version is "recommended for both 32-bit and 64-bit Windows"?
edit: actually, maybe you know what you're doin', as you suggest you are still using the 32-bit version (which means you didn't install them in the same
folder)...
I've never used the x64 version myself, so can't help you, sorry.
Oh, no. There was no problem with x64 version earlier. I was using it since Polac released VST wrapper for 64bit.
It seems that when some changes in themes were made, something is wrong in x64 version.

User avatar
mcbpete
Posts: 319
Joined: Tue Nov 22, 2011 9:45 pm

Re: problems with Buzz x64, starting build 1454

Post by mcbpete »

Yeah it's definitely a theme related error, possibly an older version of Default is used in the >1454 x64 builds. Try downloading the latest 32 bit build then dragging and dropping the Default folder in the Themes directory to the Themes drriectory of the 64bit folder

sfMan
Posts: 11
Joined: Fri Nov 25, 2011 3:48 pm

Re: problems with Buzz x64, starting build 1454

Post by sfMan »

mcbpete wrote:Yeah it's definitely a theme related error, possibly an older version of Default is used in the >1454 x64 builds. Try downloading the latest 32 bit build then dragging and dropping the Default folder in the Themes directory to the Themes drriectory of the 64bit folder
Yes, you were right. Replacing themes folder with x64 version helped.
It seems that Oskari forgot to change these files in x64 installer.

By the way. There's one more small thing in x64 version that could be made.
The default installation directory for x64 is set to user data directory, not to Program Files folder.
This is cosmetic change of course but...why not fix it :D

Post Reply