Page 1 of 1

MidiInput init failed / Syncing Buzz and Reaper

Posted: Wed Mar 07, 2012 6:55 pm
by fetus ink
I can not for the life of me figure out why I can't get my midi-in to read in Buzz. Reaper picks it up instantly, whether I start the program with it connected or turn it on while its running. Buzz, no matter what settings I try, connecting it and turning it on before I start buzz or not, constantly gives me the "MidiInput init failed" message. Any ideas?

Re: MidiInput init failed

Posted: Thu Sep 13, 2012 1:54 am
by fetus ink
I'm going to dig this up because after months of not using Buzz, I'm now syncing with Reaper as of tonight, and I'd like to get everything up and working in full again. Problem ... same thing as above. Only thing is, in the new case, I'm playing my Midi Keyboard and sending the data to Reaper. Reaper is then sending all midi data to "loopMidi" (port 1) --since midi yoke is not compatible with my x64 Reaper install --

In Buzz preferences, when I choose to receive the midi input from "loopMidi Port 1", I get this same error. If I select Midi Yoke port 1, its fine, but obviously not receiving any data as I am not using midi yoke in Reaper unless I install and move over to 32 bit (which isn't on my list of things to do. Yet.)

Someone once said a year or two ago that it may have had something to do with the M-Audio Uno unit I was using, and I never heard much more on the subject. I really would like to not believe that, mostly because:

A: It works fine with everything else I've tried it with (Cubase, Reaper, all Standalone VSTi, Sibelius, and a few other random software programs I've demo'd)

B: It used to work perfectly fine in Buzz at one point.

I'd just like to be able to play my piano, sending data either directly to buzz and routing the audio to reaper, and/or sending the midi data to reaper, routing that data to buzz, and sending all generated audio back over to Reaper.

Any help on this subject would be very much appreciated.


I installed Buzz x64 and the Midi In from the M-Audio Uno device works fine. The problem here though, is that ReaRoute does not appear in the list of drivers (made sure to install the x86 and x64 version of Reaper's ReaRoute just in case) - and also - if this does work in x64, thats ... kind of ok, but I'm missing out, knowing that some machines are not compatible. I still would love to get this all working in Buzz x86, but even help getting x64 to work would be better than nothing.

Re: MidiInput init failed

Posted: Thu Sep 13, 2012 4:40 am
by Mu_
Well I have to be honest - I didn't read your post carefully, but libraries 32 bit and 64 bit shouldn't work together.

Re: MidiInput init failed

Posted: Thu Sep 13, 2012 5:42 am
by fetus ink
I'll post these pics to make it a little more clear on what I'm doing here since I know reading and visualizing can be a pain :D

In the above picture, choosing 'ASIO' is an option, and selecting 'ReaRoute' works fine.
In this picture above, choosing 'ASIO' is /not/ an option, leaving only Polac ASIO as a form of ASIO selection, which brings me to this: viewtopic.php?p=4640#p4640

I've been told that by using MidiYoke or other virtual midi cables (such as loopMidi) you can easily sync up x64 and x86 programs together. In fact, the direct quote I saw at the Reaper forum:
Actually, simply having the 32 bit version (ReaRoute) installed is sufficient -- once it is, REAPER x64 can rearoute with 32 bit apps as well.

Re: MidiInput init failed / Syncing Buzz and Reaper

Posted: Thu Mar 27, 2014 8:36 pm
by onecircles
Hello! I'm having a similar issue trying to connect my akai MPD 26. Did you ever figure this out?

Re: MidiInput init failed / Syncing Buzz and Reaper

Posted: Tue Jun 10, 2014 4:08 am
by fetus ink
Unfortunately, no, I have never figured this out. Unfortunately this main problem was the reason I have moved away from buzz. I miss it, and I miss a lot of the generators, but its just doesn't fit within my workflow habits these days. Maybe in the future if this issue can ever be resolved I'll come back, but in the meantime, I just can't.

[edit] I remember people saying (on much older posts) that my M-Audio Midisport Uno cable had known issues, although the only issues I ever found were within buzz when I used it. I've since moved on to a rather professional setup, and still can't get it to work, so I'm doubting it was ever my cable. Just thought I'd throw that out there in case you are using the same Midisport as I used to and find old posts (probably not since I believe that was on the old forums) saying to put some blame your cable.