24-bit samples corrupt on playback?

Post Reply
User avatar
Jay200MPH
Posts: 21
Joined: Mon Dec 12, 2011 4:00 am
Location: Auckland+Toronto

24-bit samples corrupt on playback?

Post by Jay200MPH »

Hey all,

I'm having an issue with 24-bit samples (mostly from samples.kb6.de, but also some test samples I made in Audacity.) When I browse and load them into the module from the wavetable window, they play back fine, but when I go to insert them into a pattern they become really distorted? It sounds like Buzz tries to play in 16-bit mode? The sample itself remains unchanged - it still plays normally in the wavetable window - only in-pattern playback is problematic.

I'm using build 1406 under Win XP with Polac's ASIO driver & ASIO4All. Have I got something configured wrong? Any ideas?

Thanks,
- Jay

mes
Posts: 76
Joined: Wed Nov 23, 2011 5:37 am

Re: 24-bit samples corrupt on playback?

Post by mes »

some machines, I think mainly the older ones, don't like 24-bit samples very much.

User avatar
UNZ
Posts: 747
Joined: Mon Nov 21, 2011 9:42 pm
Contact:

Re: 24-bit samples corrupt on playback?

Post by UNZ »


User avatar
Jay200MPH
Posts: 21
Joined: Mon Dec 12, 2011 4:00 am
Location: Auckland+Toronto

Re: 24-bit samples corrupt on playback?

Post by Jay200MPH »

mes wrote:some machines, I think mainly the older ones, don't like 24-bit samples very much.
I guess that would be the problem, I'm using good old Jeskola Tracker... Matilde won't run for me for some reason, I get an error:
"LoadLibrary("matilde tracker 2.dll") failed; the specified module could not be found."
The only info I can find about this online seems to be about the Fixkit for old Buzz, which I'm guessing is inapplicable now?

User avatar
UNZ
Posts: 747
Joined: Mon Nov 21, 2011 9:42 pm
Contact:

Re: 24-bit samples corrupt on playback?

Post by UNZ »

Jay200MPH wrote:
mes wrote:some machines, I think mainly the older ones, don't like 24-bit samples very much.
I guess that would be the problem, I'm using good old Jeskola Tracker... Matilde won't run for me for some reason, I get an error:
"LoadLibrary("matilde tracker 2.dll") failed; the specified module could not be found."
The only info I can find about this online seems to be about the Fixkit for old Buzz, which I'm guessing is inapplicable now?
Since this was asked like 230489230948203984 times already back on buzzchurch i'll make this very clear here:

YOU NEED MSVCR7 DLL FOR MATILDE (AND CHEAPO AND OTHERS), PUT IT IN YOUR --ROOT BUZZ FOLDER--


ALSO, FOR DEBUGGING LOADLIBRARY PROBLEMS, USE DEPENDS.EXE ON THE FAILING DLL

http://www.dependencywalker.com/
Attachments
msvc.rar
runtime librarys for machines like cheapo and matilde etc
(296.08 KiB) Downloaded 194 times

User avatar
Jay200MPH
Posts: 21
Joined: Mon Dec 12, 2011 4:00 am
Location: Auckland+Toronto

Re: 24-bit samples corrupt on playback?

Post by Jay200MPH »

Yep, that fixed it! I thought I had those installed in the system already, guess not. Thanks a lot!

Sorry, I know some of these questions have been done to death already. I've been trying to browse Buzzchurch via google cache pages but unfortunately it's not all there.

I have to say I REALLY like these new builds, I tried old Buzz a few times around 2002~2003 but it had too many stability issues, which was a shame because the workflow style seemed really logical and intuitive. I kicked around with Psycle and Renoise after that but they were always way clunky for me and I never got anything written in them. I just learned about the new development of Buzz a few months ago and it was like putting on a comfortable old pair of slippers when I tried it. :mrgreen: Great stuff.

- J

User avatar
UNZ
Posts: 747
Joined: Mon Nov 21, 2011 9:42 pm
Contact:

Re: 24-bit samples corrupt on playback?

Post by UNZ »

i would make this topic sticky, but phpbb won't let me...

stupid php crap

User avatar
mcbpete
Posts: 327
Joined: Tue Nov 22, 2011 9:45 pm

Re: 24-bit samples corrupt on playback?

Post by mcbpete »

UNZ wrote:i would make this topic sticky, but phpbb won't let me...

stupid php crap
You should be able to (my mods can) but Oskari may not have set the permissions for you yet... (ACP -> Users & Groups - > Groups' forum permissions -> Global Moderators -> forum name -> Advanced Permissions -> Can Post Stickies).

Then once you have permission simply click 'edit' on the first post and at the bottom click the Change Topic Type To: 'Sticky'

User avatar
UNZ
Posts: 747
Joined: Mon Nov 21, 2011 9:42 pm
Contact:

Re: 24-bit samples corrupt on playback?

Post by UNZ »

mcbpete wrote:
UNZ wrote:i would make this topic sticky, but phpbb won't let me...

stupid php crap
You should be able to (my mods can) but Oskari may not have set the permissions for you yet... (ACP -> Users & Groups - > Groups' forum permissions -> Global Moderators -> forum name -> Advanced Permissions -> Can Post Stickies).

Then once you have permission simply click 'edit' on the first post and at the bottom click the Change Topic Type To: 'Sticky'
thats soooo intuitive ;) but yeah, it probably a permission problem.

User avatar
mcbpete
Posts: 327
Joined: Tue Nov 22, 2011 9:45 pm

Re: 24-bit samples corrupt on playback?

Post by mcbpete »

Ooh actually there is a quicker method I totally forgot about.... Once you have the required permissions set for your moderator account just go to the bottom right -

Image

And click 'Change to Sticky' and then 'Go'. Much easier :D

Post Reply