Page 2 of 2

Re: MaitoPisara

Posted: Mon Jun 15, 2015 2:49 pm
by wde
pac wrote: - I'm on Win7 and got a "Can't find dll" error. Putting it in dependency walker, I saw that it relies on an absent d3dcompiler_47.dll. Apparently, this DLL comes with Windows 8.1, but is not included in any update / service pack / redist for any previous Windows, so you're supposed (?) to distribute it with any application that uses it. (To fix the problem, I just went in program files, searched for the DLL, found that one is included with Firefox, and copied it to the Buzz folder.)
Awesome debugging pac! I have only shiny Windows 8.1 PCs here, so missed that one.

Zip file updated to include the missing dll.

Re: MaitoPisara

Posted: Tue Jun 16, 2015 1:29 am
by boombaxx
Hi how do i get the screen to show nothing comes up. Cannot see no way to get it to come up. It loads fine though

Re: MaitoPisara

Posted: Thu Jun 18, 2015 3:31 pm
by wde
boombaxx wrote:Hi how do i get the screen to show nothing comes up. Cannot see no way to get it to come up. It loads fine though
Make sure you unpack all the content in the zip to Buzz folder (where buzz.exe lives) so that also the presets are unpaked in to right place. Other than that it is up to how milkdrop handles graphics card capabilities.

I've only tested on oldish Nvidia card and Intel Atom integrated graphics.

Re: MaitoPisara

Posted: Fri Sep 09, 2016 9:09 pm
by AndersBrontosaurus do I start this thing? Installed, but then? How to run it?

Re: MaitoPisara

Posted: Thu Sep 15, 2016 6:58 am
by AndersBrontosaurus

Re: MaitoPisara

Posted: Thu Sep 15, 2016 6:06 pm
by wde
Hi Anders,

After unzipping the file to your buzz.exe folder you should be ready to go. Start Buzz, open a song and add MaitoPisara to the song. MaitoPisara is an effect machine so you need to add it to the audio chain, for example between Qsamo and Master.

Double click will open the visualization.

Re: MaitoPisara

Posted: Fri Sep 16, 2016 2:43 pm
by AndersBrontosaurus
Thanks. Eventually I found the dll and moved it to effects. Now it works!

Re: MaitoPisara

Posted: Sat Sep 17, 2016 9:04 am
by wde
Hope you find it fun and/or productive tool :)

I added the code to the first post if someone wants to take over. It's definitely hacky and messy but it works! It compiles at least using Visual Studio 2015 Community edition.

Re: MaitoPisara

Posted: Sat Sep 17, 2016 3:04 pm
by Klangkulisse
Hey wde,
MaitoPisara once worked, but doesn't anymore :cry:

I get an error message like this:

LoadLibrary("C:\Program files (x86)\Buzz\Gear\Effects\MaitoPisara.dll") failed.
%1 is not an allowable Win32 application

(may be my translation from german "zulässig" to english "allowable" is not the word that does pop up on an english system)

I checked with dependancy walker and it gives me a lot of missing files, but dependancy walker is not completely right, because I found a few.
List of missing files as a result by dependancy walker – searched them manuallly:

D3DCompiler_47.DLL > found on my system where it is supposed to be (and all other files), as it is given by your MaitoPisara zip-file.
GPSVC.DLL > found

Microsoft Visual C++ 2013 Redistributable (x86)12.0.30501 is installed
Microsoft Visual C++ 208 Redistributable (x86) is installed
DirectX 11 is installed

Would like to see Maito move again :cry:

Re: MaitoPisara

Posted: Fri Sep 23, 2016 4:04 pm
by wde

Really difficult to guide you to success here since I haven't seen that issue before. Try to remember what has been happening in your WinOS in the delta between when it worked and when not. Did you copy Buzz to another folder, false positive from some PC protection program or maybe running some PC cleanup program that is cleaning more than what was asked...?

Bing says that it might not be related to missing dependencies.

You could reinstall Buzz from install file and see if it makes any difference. Running Buzz as Admin should not make any difference but you could try it. What Win version are you running?

Re: MaitoPisara

Posted: Sat Sep 24, 2016 6:25 pm
by Klangkulisse
Thanks for holding on :)

No other folder, no messy cleanup, but I had for a period of time win 10 installed, but went back to win 7, because I had an issue with non compatible USB-drivers. That is the only major change and rechange I remember.

I reinstalled buzz (as admin) but no luck.

i am fiddling around with installing visual studio builds ... :roll:

But thank you anyway