Bugfix: Envelope gets destroyed when replacing a sample

Post Reply
User avatar
Joachip
Posts: 314
Joined: Mon Nov 21, 2011 7:21 pm
Contact:

Bugfix: Envelope gets destroyed when replacing a sample

Post by Joachip »

I've tried doing something about a problem that's been annoying me for years: Whenever you load a new sample into the wave table, it kills the envelope. In 99% of all cases I want to keep the envelope.

Now, I'm no expert in wpf, so this might not be a correct fix, but it seems to work. Everyone is welcome to test this. But keep a backup of your old file just in case.

As a minor change, I've also made so that if you select a .wav file in the right-side file browser, "Enter" now loads the sound into the wave table.

http://www.robotplanet.dk/files/buzz/Bu ... Bugfix.zip

User avatar
thOke
Posts: 319
Joined: Thu Nov 24, 2011 7:14 am

Re: Bugfix: Envelope gets destroyed when replacing a sample

Post by thOke »

Thank you! :dance:
I am not using samples in Buzz very often, but that is a useful fix!!

User avatar
Mozart von Robot
Posts: 100
Joined: Thu Mar 15, 2012 2:15 am
Location: Sweden

Re: Bugfix: Envelope gets destroyed when replacing a sample

Post by Mozart von Robot »

Oh wow, you know how to make alterations to the wavetable view? I'm not sure if I have any samples with envelope, except maybe multisample .xi files that won't load anyway, to test this with, but you wouldn't happen to know how to make this button do anything, would you?
Image
The lack of ability to play selections before trimming them is the most annoying shortcoming of the wavetable editor, and I'm losing hope that Oskari will ever return to save us.

Post Reply