new pvst beta (updated 11-Jul-2021)

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by polac »

Also worth a mention, the Roland Cloud vst3s are not working properly atm and I cannot test them anymore, as they won't install properly on my system due to a bug as it seems. What a mess argh.

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by polac »

Dexed will only change the current cartridge bank and occasionally change the envelope display for operators 5 and 6, but never tweaks any other settings or even the dials for operators 5 or 6, and it always stops sending audio - GUI is still responsive, but it'll never sing again).
Ok it works here, however you have to unselect some vst parameter in the parameter view. Only select the parameters up to 0x9a then it should work.

User avatar
HerrFornit
Posts: 361
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by HerrFornit »

Danke polac for new version !!! :)

I installed the x86 version and got afterwards a crash report by iZotope while scanning. Think it was because of the mess in the installations of iZotope plugins at different locations and double installation locations (further, effects and generators versions for same plug-in by the way, hm??). Long story, after deleting copying and buzz didn't start anymore I deleted user polac folder and rescanned all one after an other, VST3 folders inclusive. Now it works again.
Ozone crash.jpg
Ozone crash.jpg (23.3 KiB) Viewed 991 times

River Cricket
Posts: 135
Joined: Sat Dec 20, 2014 6:53 am

Re: new pvst beta (updated 29-May-2021)

Post by River Cricket »

polac wrote:
Sat May 29, 2021 7:58 pm
Dexed will only change the current cartridge bank and occasionally change the envelope display for operators 5 and 6, but never tweaks any other settings or even the dials for operators 5 or 6, and it always stops sending audio - GUI is still responsive, but it'll never sing again).
Ok it works here, however you have to unselect some vst parameter in the parameter view. Only select the parameters up to 0x9a then it should work.
Holy tamoley! I was writing up a reply, but in the time it took to do that you (basically) solved it! This also fixes the Arturia issue, though the range for those is slightly different.

It seems Dexed still will only randomize Operators 5-6, with 1-3 remaining untouched and Operator 4 being about half-randomized, but at least now they actually do work. Bizarre that I can see the values for ops 1-3 moving around in the Parameter View while randomizing, but Dexed just ignores them - so cruel! :P PeerCtrl also can't modify the op 1-3 values either... odd.

Small/useless questions: Right now I'm right-clicking the number column in F3 Parameter List to turn everything off, then click-dragging down to turn the range I want back on - is there a faster / more optimized way of doing this? And am I correct in thinking that this all stems from VST3's weird way of enabling MIDI support?

(oddly, the VST2 versions of Arturia's stuff have the same parameter list as the VST3 versions, yet randomization on them works fine even with all vst parameters selected)

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by polac »

There are often some fake midi cc parameters and a bypass parameter in vst3, these need to be unselected for randomization.

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by polac »

Ok I added the correct build number 36 to pvst now. :mrgreen:

wde
Posts: 270
Joined: Sun Jan 08, 2012 9:28 am

Re: new pvst beta (updated 29-May-2021)

Post by wde »

HerrFornit wrote:
Sat May 29, 2021 8:18 pm
Danke polac for new version !!! :)

I installed the x86 version and got afterwards a crash report by iZotope while scanning. Think it was because of the mess in the installations of iZotope plugins at different locations and double installation locations (further, effects and generators versions for same plug-in by the way, hm??). Long story, after deleting copying and buzz didn't start anymore I deleted user polac folder and rescanned all one after an other, VST3 folders inclusive. Now it works again.
Ozone crash.jpg
New version! :dance:

I'm having the same issue with Ozone 8 and I'm not able to avoid it. Loading a song with crashing ozone unfortunately handicaps all other polac vst instances and causes issues when saving the song again.

How did you get it to work?

User avatar
HerrFornit
Posts: 361
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by HerrFornit »

wde wrote:
Mon May 31, 2021 4:19 pm

New version! :dance:

I'm having the same issue with Ozone 8 and I'm not able to avoid it. Loading a song with crashing ozone unfortunately handicaps all other polac vst instances and causes issues when saving the song again.

How did you get it to work?
Well, I can't remember all steps, but I think the deleting of the \user\polac folder (automatically recreated) and then adding the searchfolders in PVST preferences did it.(Well I have to admit that I avoid to install VST3 in favour of VST2 :) also by manual deleting .vst3, I think I have that done, too before)

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by polac »

Well I have to admit that I avoid to install VST3 in favour of VST2 :) also by manual deleting .vst3
That's what i'm doing too. :mrgreen:

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by polac »

I'm having the same issue with Ozone 8 and I'm not able to avoid it. Loading a song with crashing ozone unfortunately handicaps all other polac vst instances and causes issues when saving the song again.
Are you using the vst3 version? I did some changes on the vst3 wrappers but did not test that much here i have to admit.

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by polac »

I tested now ozone 8 elements, crashes here too(the vst3 version), will check.

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by polac »

I tested now ozone 8 elements, crashes here too(the vst3 version), will check.
Seems i cannot fix this easily it crashes in ozone code. And I didn't change much in the initialization, I think it has something to do with the newer vst3sdk. With the older vst3sdk i get it to work which is odd. So the only fix is to stay at pvst build 35 atm.

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 29-May-2021)

Post by polac »

Ok I found the bug, I'm wondering why other vst3 did work. I will upload a new loader version tomorrow. Sorry for this bug argh. They changed(Steinberg) something with the conversion from TUID to FUID, the vst3s were not able to query certian interfaces anymore.

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 1-Jun-2021)

Post by polac »

Bump, uploaded a new version fixing the Ozone problem(and probably fixing the Roland Cloud problems too). I cannot test Roland Cloud anymore because of a bug with the Cloud Manager which does not install the Zenology plugin(it did at first then i uninstalled it, after this an reinstall was impossible for me).

User avatar
thOke
Posts: 342
Joined: Thu Nov 24, 2011 7:14 am

Re: new pvst beta (updated 1-Jun-2021)

Post by thOke »

Thanks. Zenology loads again after disappearing for a while here too.
Last edited by thOke on Wed Jun 02, 2021 6:14 pm, edited 1 time in total.

User avatar
HerrFornit
Posts: 361
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: new pvst beta (updated 1-Jun-2021)

Post by HerrFornit »

Cool quick fix !!! :dance: Thank you!

wde
Posts: 270
Joined: Sun Jan 08, 2012 9:28 am

Re: new pvst beta (updated 1-Jun-2021)

Post by wde »

polac wrote:
Tue Jun 01, 2021 7:46 pm
Bump, uploaded a new version fixing the Ozone problem(and probably fixing the Roland Cloud problems too).
Thanks, everything seems to work perfectly now!

polac
Posts: 369
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 1-Jun-2021)

Post by polac »

Bump, some bugfixes with the bit bridge.

User avatar
IXix
Posts: 974
Joined: Wed Nov 23, 2011 3:24 pm

Re: new pvst beta (updated 11-Jul-2021)

Post by IXix »

Thanks polac! I can't afford much but I sent a little donation. Hopefully it's enough to buy a beer or two.

User avatar
HerrFornit
Posts: 361
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: new pvst beta (updated 1-Jun-2021)

Post by HerrFornit »

polac wrote:
Sun Jul 11, 2021 9:49 am
Bump, some bugfixes with the bit bridge.
Thank you! I will test it next week when I am at home.

Post Reply