new pvst beta (updated 4-Sep-2021)

User avatar
temporalsounds
Posts: 93
Joined: Sun Jan 27, 2019 3:29 pm
Contact:

Re: new pvst beta (updated 1-Jun-2021)

Post by temporalsounds »

polac wrote:
Sun Jul 11, 2021 9:49 am
Bump, some bugfixes with the bit bridge.
Thank you

User avatar
HerrFornit
Posts: 375
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: new pvst beta (updated 11-Jul-2021)

Post by HerrFornit »

Hi polac. i have an issue with some vst. they steal the focus and buzz is disappearing into the background. Dont know if that is an issue of pvst at all. it happens with tischmeyers tt meter or the meldaplugins. its an older issue. perhaps it can be solved by an existing option of pvst?

River Cricket
Posts: 136
Joined: Sat Dec 20, 2014 6:53 am

Re: new pvst beta (updated 11-Jul-2021)

Post by River Cricket »

HerrFornit wrote:
Tue Jul 13, 2021 1:40 pm
Hi polac. i have an issue with some vst. they steal the focus and buzz is disappearing into the background. Dont know if that is an issue of pvst at all. it happens with tischmeyers tt meter or the meldaplugins. its an older issue. perhaps it can be solved by an existing option of pvst?
I use a handful of Melda stuff and haven't noticed this - any particular plugins / steps to replicate so I can try it on my end?

Also, I mentioned this in another thread, but it seems the VST effects loader hasn't been updated with the new JUCE popup window workaround. VST instruments are now fine in that regard, though.

User avatar
HerrFornit
Posts: 375
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: new pvst beta (updated 11-Jul-2021)

Post by HerrFornit »

River Cricket wrote:
Wed Jul 14, 2021 12:22 am
HerrFornit wrote:
Tue Jul 13, 2021 1:40 pm
Hi polac. i have an issue with some vst. they steal the focus and buzz is disappearing into the background. Dont know if that is an issue of pvst at all. it happens with tischmeyers tt meter or the meldaplugins. its an older issue. perhaps it can be solved by an existing option of pvst?
I use a handful of Melda stuff and haven't noticed this - any particular plugins / steps to replicate so I can try it on my end?
thanky for your help. I am not at home so I can decribe it not exactly. It happens with Mequaliser and Mbandpass when you open the gui and close it, i guess. You say your pvst has not been updated due to your juce tweak? Then you can try to find out your pvst version and post it here?

River Cricket
Posts: 136
Joined: Sat Dec 20, 2014 6:53 am

Re: new pvst beta (updated 11-Jul-2021)

Post by River Cricket »

HerrFornit wrote:
Wed Jul 14, 2021 8:50 am
River Cricket wrote:
Wed Jul 14, 2021 12:22 am
HerrFornit wrote:
Tue Jul 13, 2021 1:40 pm
Hi polac. i have an issue with some vst. they steal the focus and buzz is disappearing into the background. Dont know if that is an issue of pvst at all. it happens with tischmeyers tt meter or the meldaplugins. its an older issue. perhaps it can be solved by an existing option of pvst?
I use a handful of Melda stuff and haven't noticed this - any particular plugins / steps to replicate so I can try it on my end?
thanky for your help. I am not at home so I can decribe it not exactly. It happens with Mequaliser and Mbandpass when you open the gui and close it, i guess.
I'll poke around with these and see what happens. I know things do get weird if you have GUIs visible in "normal" pVST mode and then try to open a GUI of a machine that loads in "non-embedded" pVST mode (first checkbox when hitting ctrl+alt for Bridge settings, see below screenshot)
Image
HerrFornit wrote:
Wed Jul 14, 2021 8:50 am
You say your pvst has not been updated due to your juce tweak? Then you can try to find out your pvst version and post it here?
Sorry if I wasn't clear.

There's two VST machines in the Polac suite: Polac VST 1.1 (which is used for Effects) and Polac VSTi 1.1 (which is used for Generators). The most recent update of Polac suite fixed a really irritating bug with JUCE synths that use pop-up / drop-down windows, but only in Polac VSTi 1.1. In VST (no i) 1.1, you still have to disable the embedded VST GUI in order to use the drop-down menus in plugins such as the ones from Valhalla or the ones from Tokyo Dawn.

It's a pretty simple fix from what I remember, but without access to the source I can't really offer much :)

User avatar
HerrFornit
Posts: 375
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: new pvst beta (updated 11-Jul-2021)

Post by HerrFornit »

thanx River Cricket for caring and clarification :) . I thought the embedded gui thing is needed for x64 plugins only. I should have installed x86 (vst2) versions of Melda only. I will check all that next week when I have access to my music pc again ;)

River Cricket
Posts: 136
Joined: Sat Dec 20, 2014 6:53 am

Re: new pvst beta (updated 11-Jul-2021)

Post by River Cricket »

HerrFornit wrote:
Wed Jul 14, 2021 11:32 pm
thanx River Cricket for caring and clarification :) . I thought the embedded gui thing is needed for x64 plugins only. I should have installed x86 (vst2) versions of Melda only. I will check all that next week when I have access to my music pc again ;)
Yeah, Embedded GUI is for certain plugins only - JUCE is one popular framework (sort of like how SynthEdit used to be) where the resulting plugins will require Embedded GUI if they use drop-down menus. Doesn't matter if they're x86 or x64.

I generally use x64 VST2s. VST3's require a rescan to show up, and even just "scan for new" usually takes upwards of five minutes to complete for some reason.

River Cricket
Posts: 136
Joined: Sat Dec 20, 2014 6:53 am

Re: new pvst beta (updated 11-Jul-2021)

Post by River Cricket »

I believe I can confirm HerrFornit's issue. Either that, or I've found a separate issue.

This is only with the latest pVST version. Adjusting any control on pretty much any non-JUCE VST immediately causes focus to drop, regardless of whether Prevent Focus Stealing is checked. This means it's impossible to use QWERTY to play notes while adjusting dials with the mouse.

I say "pretty much" any, because old SynthEdit-era VSTs are fine (tested/confirmed with ASynth and iloSynth1). It's what I'll scientifically term "VSTs which require enabling Prevent Focus Stealing" like Serum, Arturia V Collection, GForce ImpOSCAR and Oddity2 which are all affected.

Ironically, JUCE synths are mostly fine now (tried Cherry Audio's CA2600 to confirm - it can be a little bit wonky, a held QWERTY note will momentarily drop when you click the mouse, but usually picks right back up after a brief hiccup).

Steps to replicate:

1. Load Serum in Buzz
2. Hold "Q" to get a lovely C-5 sawtooth
3. While still holding Q, use mouse to adjust any control on the synth
4. Note immediately drops, the title bar must be clicked before focus will be regained

I'll be rolling back to the previous .36 version, as this makes .37 kinda unusable for my sound design workflow. I think this should probably be a checkbox option, "Enable/Disable JUCE Compatibility Mode".

User avatar
HerrFornit
Posts: 375
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: Stealing Focus by Plugins

Post by HerrFornit »

Hi,

in the attachment you find a zip file containing an example video. (32bit versions used, Win10x64pro)
It happens when more than one instances of the plugin are opened with GUI, in the moment of closing GUI, or another plugin (TT meter) and meldaplugins are opened. It does not happen when only one of the plugin is opened. It happens with v36 and v37 and with option "prevent stealing focus" checked. Last is probably another focus than in my example? :)
StealingFocus2.zip
(2.02 MiB) Downloaded 149 times
StealingFocus1.zip
(1.2 MiB) Downloaded 146 times

User avatar
Joachip
Posts: 349
Joined: Mon Nov 21, 2011 7:21 pm
Contact:

Re: new pvst beta (updated 11-Jul-2021)

Post by Joachip »

Ohhhh, so the browser suddenly pops in front.

I said in another thread that I hadn't experienced this problem (because i thought it was something PVST related), but after watching the video I'll take that back. What your video shows is a rather common problem in Windows, and I've seen it with many different combinations of software. It even happened with the insurance related .NET software we made at my previous work.

I'm fairly certain this is a bug in Windows.

User avatar
temporalsounds
Posts: 93
Joined: Sun Jan 27, 2019 3:29 pm
Contact:

Re: Stealing Focus by Plugins

Post by temporalsounds »

HerrFornit wrote:
Tue Jul 20, 2021 7:08 pm

It happens when more than one instances of the plugin are opened with GUI, in the moment of closing GUI, or another plugin (TT meter) and meldaplugins are opened. It does not happen when only one of the plugin is opened. It happens with v36 and v37 and with option "prevent stealing focus" checked. Last is probably another focus than in my example? :)
StealingFocus2.zip
StealingFocus1.zip
I don't know
I tried Melda BandPass in 64bit Buzz
No issues under Win 8.1 x64 :?:
EDIT : PVST v37
Last edited by temporalsounds on Thu Jul 22, 2021 6:32 am, edited 1 time in total.

User avatar
HerrFornit
Posts: 375
Joined: Sat Feb 25, 2017 12:27 pm
Location: Steinberg UR12, AKG 702, Old Hi-Fi, A-49, PC: Xeon 1230v3 8GB, Win10x64pro, Buzz 1503x86
Contact:

Re: Stealing Focus by Plugins

Post by HerrFornit »

@ joachip, thanx for reply. So unfortunately polac can do nothing against this kind of stealing of focus :( Have to complain at MS

@ temporalsounds. Ok its then perhaps WIn10 related and/or Buzzx86 related (?) Thanx a lot for video! I used oCam by the way ;)

EDIT: Its gone in compatibility mode for Win8 :D !! (disadvantage: Loading time of songs is significantly longer, mainly MTpowerdrumkit :( )

EDIT2: River Crickets focus does mean "active window" ? Seems he discovered another issue.

EDIT3: Sorry the error still appears, probably a between-app-interaction problem, lost :(

River Cricket
Posts: 136
Joined: Sat Dec 20, 2014 6:53 am

Re: Stealing Focus by Plugins

Post by River Cricket »

HerrFornit wrote:
Tue Jul 20, 2021 7:08 pm
Hi,

in the attachment you find a zip file containing an example video. (32bit versions used, Win10x64pro)
It happens when more than one instances of the plugin are opened with GUI, in the moment of closing GUI, or another plugin (TT meter) and meldaplugins are opened. It does not happen when only one of the plugin is opened. It happens with v36 and v37 and with option "prevent stealing focus" checked. Last is probably another focus than in my example? :)
StealingFocus2.zip
StealingFocus1.zip
Oh wow, yes, this is something different than what I'm talking about. And I've noticed it too, it's just become one of those things you kinda get used to. I think we're on different Windows versions, so maybe Chrome is the common culprit? I've seen Chrome stealing focus from itself at times too...

polac
Posts: 373
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 11-Jul-2021)

Post by polac »

Hmm, seems I fixed the JUCE problem by removing the WS_CHILD flag, however there are still problems with certain plugins, namely the Cherry Audio ones. Menu/combobox popups are not showing up there and are flickering. The only workaround is here to still disable the embedded gui. :|

Don't know if these are also using JUCE, but i don't think so.

Edit: it uses JUCE, argh.
Last edited by polac on Sat Sep 04, 2021 10:18 am, edited 1 time in total.

polac
Posts: 373
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 11-Jul-2021)

Post by polac »

Also a thing to keep in mind: if you switch from embedded gui to popup gui in the vst bridge(and vice versa), you have to restart Buzz. Otherwise saving to project is not working properly as i just found out. Fixing this would be really a chore, but restarting fixes the issue.

Edit: Nonsense, i checked the code there shouldn't be a problem, it was another unrelated issue i most likely fixed.
Last edited by polac on Sat Sep 04, 2021 8:22 pm, edited 1 time in total.

polac
Posts: 373
Joined: Wed Nov 23, 2011 9:19 am
Contact:

Re: new pvst beta (updated 4-Sep-2021)

Post by polac »

I did a small loader update, i removed the *so called* WS_CHILD fix from b37 again, it did work only work with very few plugins as it seems, and it is either way the more correct way. JUCE said they would fix the issue from their side, therefore newer plugins hopefully are working better then.

Post Reply