MaitoPisara

wde
Posts: 213
Joined: Sun Jan 08, 2012 9:28 am

Re: MaitoPisara

Post by wde »

pac wrote: - I'm on Win7 and got a "Can't find dll" error. Putting it in dependency walker, I saw that it relies on an absent d3dcompiler_47.dll. Apparently, this DLL comes with Windows 8.1, but is not included in any update / service pack / redist for any previous Windows, so you're supposed (?) to distribute it with any application that uses it. (To fix the problem, I just went in program files, searched for the DLL, found that one is included with Firefox, and copied it to the Buzz folder.)
Awesome debugging pac! I have only shiny Windows 8.1 PCs here, so missed that one.

Zip file updated to include the missing dll.

boombaxx
Posts: 270
Joined: Tue Dec 06, 2011 6:54 pm

Re: MaitoPisara

Post by boombaxx »

Hi how do i get the screen to show nothing comes up. Cannot see no way to get it to come up. It loads fine though

wde
Posts: 213
Joined: Sun Jan 08, 2012 9:28 am

Re: MaitoPisara

Post by wde »

boombaxx wrote:Hi how do i get the screen to show nothing comes up. Cannot see no way to get it to come up. It loads fine though
Make sure you unpack all the content in the zip to Buzz folder (where buzz.exe lives) so that also the presets are unpaked in to right place. Other than that it is up to how milkdrop handles graphics card capabilities.

I've only tested on oldish Nvidia card and Intel Atom integrated graphics.

User avatar
AndersBrontosaurus
Posts: 501
Joined: Mon Feb 25, 2013 9:31 am
Location: Fellingsbro

Re: MaitoPisara

Post by AndersBrontosaurus »

Eeehhh...how do I start this thing? Installed, but then? How to run it?

User avatar
AndersBrontosaurus
Posts: 501
Joined: Mon Feb 25, 2013 9:31 am
Location: Fellingsbro

Re: MaitoPisara

Post by AndersBrontosaurus »

Bumping...

wde
Posts: 213
Joined: Sun Jan 08, 2012 9:28 am

Re: MaitoPisara

Post by wde »

Hi Anders,

After unzipping the file to your buzz.exe folder you should be ready to go. Start Buzz, open a song and add MaitoPisara to the song. MaitoPisara is an effect machine so you need to add it to the audio chain, for example between Qsamo and Master.

Double click will open the visualization.

User avatar
AndersBrontosaurus
Posts: 501
Joined: Mon Feb 25, 2013 9:31 am
Location: Fellingsbro

Re: MaitoPisara

Post by AndersBrontosaurus »

Thanks. Eventually I found the dll and moved it to effects. Now it works!

wde
Posts: 213
Joined: Sun Jan 08, 2012 9:28 am

Re: MaitoPisara

Post by wde »

Hope you find it fun and/or productive tool :)

I added the code to the first post if someone wants to take over. It's definitely hacky and messy but it works! It compiles at least using Visual Studio 2015 Community edition.

User avatar
Klangkulisse
Posts: 291
Joined: Tue Nov 22, 2011 12:20 am
Location: ••• Düsseldorf ••• Made of Light

Re: MaitoPisara

Post by Klangkulisse »

Hey wde,
MaitoPisara once worked, but doesn't anymore :cry:

I get an error message like this:

LoadLibrary("C:\Program files (x86)\Buzz\Gear\Effects\MaitoPisara.dll") failed.
%1 is not an allowable Win32 application

(may be my translation from german "zulässig" to english "allowable" is not the word that does pop up on an english system)

I checked with dependancy walker and it gives me a lot of missing files, but dependancy walker is not completely right, because I found a few.
List of missing files as a result by dependancy walker – searched them manuallly:

D3DCompiler_47.DLL > found on my system where it is supposed to be (and all other files), as it is given by your MaitoPisara zip-file.
API-MS-WIN-CORE-WINRT-L1-1-0.DLL > NOT found
API-MS-WIN-CORE-WINRT-ROBUFFER-L1-1-0.DLL > NOT found
API-MS-WIN-CORE-WINRT-STRING-L1-1-0.DLL > NOT found
DCOMP.DLL > NOT found
GPSVC.DLL > found
IESHIMS.DLL > found


Microsoft Visual C++ 2013 Redistributable (x86)12.0.30501 is installed
Microsoft Visual C++ 208 Redistributable (x86) is installed
DirectX 11 is installed

Would like to see Maito move again :cry:

wde
Posts: 213
Joined: Sun Jan 08, 2012 9:28 am

Re: MaitoPisara

Post by wde »

Hi,

Really difficult to guide you to success here since I haven't seen that issue before. Try to remember what has been happening in your WinOS in the delta between when it worked and when not. Did you copy Buzz to another folder, false positive from some PC protection program or maybe running some PC cleanup program that is cleaning more than what was asked...?

Bing says that it might not be related to missing dependencies.

You could reinstall Buzz from install file and see if it makes any difference. Running Buzz as Admin should not make any difference but you could try it. What Win version are you running?

User avatar
Klangkulisse
Posts: 291
Joined: Tue Nov 22, 2011 12:20 am
Location: ••• Düsseldorf ••• Made of Light

Re: MaitoPisara

Post by Klangkulisse »

Thanks for holding on :)

No other folder, no messy cleanup, but I had for a period of time win 10 installed, but went back to win 7, because I had an issue with non compatible USB-drivers. That is the only major change and rechange I remember.

I reinstalled buzz (as admin) but no luck.

i am fiddling around with installing visual studio builds ... :roll:

But thank you anyway

Post Reply